When I connect the wallet, the website told me: window.ethereum.enable is not a function

When I connect the wallet, the website told me: window.ethereum.enable is not a function

4 Likes

This looks like a systematic error. Have you ever tried to close the page and log in to your wallet again? If you haven’t tried, I suggest you try it first. :slightly_smiling_face:

1 Like

I have tried, and I restarted my computer, but it’s not resolved.

Hello, please wait patiently for the professional’s answer. I haven’t encountered such a problem personally, so I don’t have any better suggestions for the time being. I’m sorry :relieved:

I have the same error

Hello @nara1 and @tokito and welcome to the community.

Can you give more details on the issue? Are you using the extension or the mobile app? If you are using the extension, what browser are you using? If it’s the mobile app, which version of the app do you currently have? Did you update MetaMask to the last version?
Latest version of the extension for browser is 10.14.6 and latest mobile app version is 5.1.1.

I meet the error with the extension, and my browser is Chrome102.0.5005.61. The version of the extension is 10.14.6

The latest version of Chrome and Metamask is installed on Windows 10. The iPad app works. Metamask works in Brave and Mozilla. Does not work only in Chrome. Reinstalling Chrome and Metamask doesn’t help. When trying to connect to Pancakeswap, this error is “window.ethereum.enable is not a function”. When trying to connect to Uniswap, another error occurred. It is impossible to connect the wallet to any service or website, in any networks.

@nara1 and @tokito thank you for sharing. Please submit a ticket to our support team about your issues at https://metamask.zendesk.com/hc/en-us , by clicking “Start a Conversation”
support

The issue needs further investigation, and hopefully this will accelerate the process of finding a solution for you.

I can’t click the button.Can you provide another way?

This article should help out with that issue so you can proceed with contacting support.

You can try delete Finnie.

6 Likes

the chrome is some wrong

1 Like

This topic was automatically closed after 29 days. New replies are no longer allowed.