Window pops up, no content renders inside it

Hi! I’ve used MetaMask for years.

I’ve started experiencing an issue where if I click on the MM extension the usual window renders, but nothing in the window does:

(I have a screenshot, but apparently can’t upload it, nor link to it)

I’m using Firefox 78.12.0esr (64-bit) on Debian. This has not affected my Brave or Tor browsers, but I have accounts on the Firefox install that I would like to be able to access. I’ve tried disabling and re-enabling the extension. Recovering the seed phrase in order to reinstall would be painful.

I’ve tried debugging the extension, and will copy-paste the output from the console (since I can’t put pictures inline as a new user):

Some cookies are misusing the recommended “sameSite“ attribute 319

Setting up Sentry Remote Error Reporting for 'production': SENTRY_DSN         initSentry.js:1:1426

Content Security Policy: The page’s settings blocked the loading of a resource at eval (“script-src”).          lockdown.js:2105:39

asm.js type error: expecting argument type declaration for 'e' of the form 'arg = arg|0' or 'arg = +arg' or 'arg = fround(arg)'         bg-libs.js:16:187282

UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code. ExtensionStorageIDB.jsm:831
    normalizeStorageError resource://gre/modules/ExtensionStorageIDB.jsm:831
    method chrome://extensions/content/child/ext-storage.js:273
    AsyncFunctionThrow self-hosted:698

Error: An unexpected error occurred
    h moz-extension://125500d6-db15-4fb6-bc31-b59dc631b8ab/initSentry.js:8

uncaught exception: null

Unfortunately I do not know how to make heads or tails out of that output.

Could someone help me?