Account does not have permisson for this transaction

I added the CIC chain network and sent some Crazy Internet Coin (CIC) tokens to my MetaMask wallet extension (Firefox). This account is connected to a ledger nano x. Now I am trying to send the tokens to another address, but it doesn’t work. Ledger is connected, the ethereum app is running and I am asked to confirm the transaction on ledger. But each time I do so MetaMask shows an error: Transaction 0-failed. [ethjs-query] while formatting outputs from RPC. ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“account does not have permisson for this transaction”}}}’. What can I do? Thanks for your help.

Hello @Reto.

Try clearing cache and cookies in your browser.
If that doesn’t work, try removing and reconnecting the Ledger Nano X to your MetaMask wallet. Let me know if that helps.
Another browser with the MetaMask extension installed, to which you connect your Ledger could be another solution if the above doesn’t work.


Thank you Chinzilla. Clearing Cache and Cookies didn’t work.
I completely removed the MetaMask extension from Firefox and reinstalled it in Chrome. Then I imported my ledger wallet with my seed phrase. If I send tokens from the ledger live application now, I still have to confirm the transaction on my ledger device. But this is NOT the case if I send the tokens from the MetaMask extension (same wallet of course)! How can I fix this? If I choose the option “connect hardware wallet” in the MetaMask extension I can afterwards choose ledger nano x. Then I need to select an account. But the ledger account is already selected and it shows the follwing message: “this account has already been connected to MetaMask”. So the confirm button is inactive. Of course the account has already been connected to MetaMask, but how do I configure my ledger nano x in a way that the transactions made from the Chrome MetaMask extension need to be confirmed on my ledger device as well (just as it is the case in the ledger live app)? Thank you very much for your help!

Found the solution myself. I shouldn’t import the ledger wallet with my seed phrase! Instead I created a new MetaMask wallet in the browser extension and connected the hardware wallet afterwards. Now it works!
I will add CIC network and test if I can send tokens now.


Well, I tested it and I still cannot send CIC tokens! MetaMask still shows the same error: Transaction 0-failed. [ethjs-query] while formatting outputs from RPC. ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“account does not have permisson for this transaction”}}}’. What can I do? Appreciate any help!

@Reto do you have any pending or stuck transactions to your wallet? Have you tried increasing gas to see if the failure still happens?

I’m not familiar with this network, but starting at the basics to see if we can resolve.


Thank you KBeeTheCypybara, I don’t see any pending transactions. I uninstalled and reinstalled the MetaMask extension, so there shouldn’t be any. Increasing the gas fee didn’t help either.

Thanks! Confirming you have the latest update of MetaMask and the most recent firmware update installed for Ledger?


yes and yes… Maybe there is a problem with that CIC network and Ledger?

I can’t confirm this because I am not familiar with the network. You can open a help desk ticket with both MetaMask and Ledger (open separate tickets).

For MetaMask, you can get to Help Desk through your MetaMask extension or mobile app. Go to drop down menu > support > choose the blue Start a Conversation bubble. Or visit and choose the blue Start a Conversation bubble

For Ledger, here is their help center: click the ‘contact us’ purple button in the lower right hand corner of screen.


When I search CIC on Ledger’s site, it comes up with an exchange for CIC (not your token). When you reach out to them, clarify the specific token you’re talking about so they don’t mix up with this :slight_smile:

1 Like

Thank you so much for your help! In the meantime I contacted the CIC support team and it turned out that they use some kind of whitelisting of all addresses in their network for security reasons. For some unknown reasons my personal address was not whitelisted but they changed it. It works now! Thanks again!


This topic was automatically closed after 30 days. New replies are no longer allowed.