BUSD from binance not shown in Metamask

I have send BUSD in BEP20 to Metamask. But not visible in Metamask.

1 Like

Hello and welcome to MetaMask community :slight_smile:
Do you have the Binance Smart chain network added to your MetaMask wallet? If so, maybe you just need to add the token manually:
Click on Import token → Custom token and introduce the following information:
Contract: 0xe9e7CEA3DedcA5984780Bafc599bD69ADd087D56

1 Like

hello How to add a custom token

2 Likes

i have added BUSD token also. But still showing 0 in my MM.

Sometimes, if you cannot see the tokens in your wallet, but the transaction was successful on the blockchain explorer you can try the steps from this article MetaMask states “Balance may be outdated”, displays in orange, or ETH not added to balance

and make sure you have enabled the browser permissions and the latest version of the app/browser extension.

Hi Bro, I used this method also. Still not Showing.

Whenever i select Eth mainet for few sec the value of BUSD was shown in Eth.

But i remember that transfer was done in BEP20

Ok, but usually if you select BEP20 for a transfer, the tokens are transferred on the Binance smart chain network, and not on the Ethereum Mainnet. Try adding the Binance smart chain network and then importing the token manually.

Ok Thanks Bro.

I will try once again

Sure, glad to help :slight_smile:

@aaravind007 As mentioned by @Urban.Moods and @998755, you need to add both Smart Chain network and the token contract address to be able to view the token balance in your wallet. In case you have done so and still are not able to see them in your wallet, please share the transaction ID and we will take a look at it. NEVER share the private key and secret recovery phrase with anyone.

3 Likes