Can not restore asost Assets and Lack of Support from Metamask - Seeking Advicesests after resetting iphone settings

Hey MetaMask users,

I need your help and advice regarding a frustrating situation I’ve encountered. After having to delete and reimport my seed phrase, I’ve lost access to my assets. MetaMask support claims I wrote down the wrong seed phrase, despite my certainty that it’s correct. Meanwhile, the value of my assets continues to decline, and MetaMask seems unresponsive.

I’ve tried using the third-party website they suggested, but it hasn’t helped. I even showed them my transactions on etherscan, but they still couldn’t assist me in recovering my account. This lack of support is incredibly disappointing.

If anyone has faced a similar issue or has any advice, please share your experiences here. I’m desperate to find a solution and regain control of my assets. Any suggestions or insights would be greatly appreciated. It’s my hope that by sharing our stories, we can either find a resolution or encourage MetaMask to improve their support system.

1 Like

Have you tried to use another wallet than MetaMask ? If you have the correct seed phrase, you should be able to use it in other wallets and then gain access to your assets. I know this is not the solution you want, but it might help you getting control of your assets again and prove that you got the right seed phrase.


This topic was automatically closed after 30 days. New replies are no longer allowed.