Cancel transaction stuck for days. Will not allow me to speed up

Several days ago I bought ETH with fiat through Wyre. I (stupidly) connected my account to ERSDL intending to stake for ERSDL coins, but I hadn’t actually swapped for any ERSDL yet. So I tried to cancel the transaction. So now I have a transaction in my metamask account to “Approve UNI-V2 Spend Limit.” It’s been pending for 5 days. I submitted a cancellation request within minutes of submitting the Spend Limit request. Both have been pending for days now. I have tried over and over to speed up the cancellation request. I now have 10 cancellation requests, each time it increases the gas fees, but never goes through. Now when I click “speed up” it says “Transaction failed - insufficient funds.” I just bought another $200 of ETH and it still is saying insufficient funds. This sucks. I have all this money stuck in this account and am unable to do anything until this cancel request goes through but it doesn’t look like it’s ever going to if I can’t increase the gas fees. Help??

1 Like

I’m in the exact same boat. Also, my mobile wallet tells me nothing was transferred out but my Chrome extension indicates zero ERDSL.

My transaction eventually timed out and failed. I lost my gas fees in the process (about $25) but at least my account isn’t stuck anymore. Hope you had luck getting yours figured out.

Having the same issue. Stuck on pending.

How long did it take until it timed out and failed?

What gas fees did you order? I always have problems deciding what to set.

I have the same issue sending matic from metamask to Matic mainnet…
Transaction Pending now for 7 days…
I spent over $150 trying to speed up and cancel the transaction… each time it charges me and never does anything.

What is going on?
Is this Metamask issue, miners issue, network issue, ether issue?
HELP for gad sakes.