Desperate: Transaction error persists after Clear Activity and Custom Nonce :-(

Hello Forum!

I’m a bit desperate😥, maybe some expert could help?! hoping

I always get “Transaction xx failed [ethjs-query] while formatting outputs from RPC”… Tried several networks/dApps…

A) I already set Customize transaction nonce to “on”.
Tried different nonce values when starting a transaction, e.g.:
I entered 15 → error: nonce too low
I entered 16 → error: nonce too high
I tried all values down to 1.

B) I did “Clear activity tab data”
No change.

I’m runninng out of ideas :expressionless:

What else can I do?

BTW: All funds are gone related to the transacgtions with errors. I hope I would get them back if I completedly reset MetaMask and started fresh from the seeds? :expressionless:

Thanks for any help!!!

Check your wallet address on block explorer on the network you are having issues on, for gas fee settings of the first stuck transaction and the nonce of it and use this article to help you cancel any pending ones. Always start with the oldest pending nonce transaction.

Always check your wallet on block explorer for anything not working.


Hmmm, I looked up my wallet address on block explorer:

There are many transactions. All of them with SUCCESS.
(Also the ones, where MM-Shows an error.)

No idea what I should do?

BTW, in MetaMask neither clicking on

  • show in block explrorer, nor
  • copy transaction id
    works (when clicking on the transaction with an error).

After doing the “Clear activity tab data”, the activity tab of MetaMask is quite empty, though. Most error messages are not visible any more.

I’m out of ideas. :neutral_face::roll_eyes: The only “solution” i can think of is: Deleting MetaMask and start totally fresh.

Probably with a different Wallet; don’t want to run into the same problem again. Especially as I have no clue at all, WHY this happened in the first place (to avoid it in the future).

Update: I “solved” the problem: Deleting Arbitrum-Network and adding it again to MetaMask.

Somehow I managed to overrite my Arbitrum Network settings (I honestly have no idea, how this could have happened) and it had the following entry for RPC-URL:
(see attached screenshot)

After adding Arbitrum-Network to MetaMask it is:
(links not allowed)
and everything seems to work.

Should I be concerned? Any idea how I could have overwritten this RPC settings? :question::question::question: confused (To avoid in future.)

Thanks for any help!

Glad you found a solution :slight_smile:

You can overwrite this RPC settings by just editing it and copy/pasting or typing in another RPC URL


This topic was automatically closed after 30 days. New replies are no longer allowed.