EOS Tokens Not Loading

Hey Guys,
Trying to send EOS tokens to an exchange, have added EOS Mainnet but the tokens which show on Etherium Mainnet (and Ethplorer) are not showing there.

I get the message “We had trouble loading your token balances”

I read updating to latest version of Metamask might help. I use the browser extension, so shouldn’t it automatically update? I have logged out and in and still have version 10.5.2. But the latest version is 10.6.0

Any ideas much appreciated :slight_smile:

Hi @sasha144 so you see your EOS here: https://etherscan.io/ ?

EOS Mainnet is not a Ethereum Mainnet :slightly_smiling_face: these are 2 different networks.

Hi @Luigi yes, my EOS is there.

I am aware they are different networks, I have manually set up Metamask to connect to a new network (EOS Mainnet) but the tokens in my Metamask account are not showing, I just get an error message saying they are unable to load them.

The ERC-20 tokens EOS on ETH network is forever locked since the mainnet launched.
You have to get an EOS private key. I don’t know if it still works.

You will find everything on the eosauthority site :point_down:

EOS Community Forum:

Hi @Luigi thanks for the info but I already am registered and have a private key. My ERC20 tokens were exchanged for EOS years ago.

The tokens show up in my Metamask wallet on Etherium Mainnet but won’t load when I connect to EOS Mainnet.

@sasha144 good :+1: you can see your EOS on this site https://bloks.io/?

Try MetaMask wallet on another browser :slightly_smiling_face: or Anchor wallet: Getting Started with Anchor Wallet - Anchor Wallet - EOSCommunity.org Forums for EOS Mainnet

1 Like

Yes I see them @Luigi :slight_smile:

Do you think it’s worth deleting and re-installing Metamask?

@sasha144 you try :slightly_smiling_face: but don’t forget to save your MetaMask seed phrase and private keys imported accounts.

So I tried everything above, now have the latest version of metamask. When I reinstalled, I was able to re-import my EOS tokens and they showed up again on the Etherium Mainnet.

But they don’t show on the EOS Mainnet and I still get the error message “We had trouble loading your token balances”

I have emailed Metamask support - 9 days, no reply. Any ideas what to do next @Luigi ? :smile:

@sasha144 that’s weird :thinking: and did you try Anchor wallet?
Import EOS privat key to this wallet: https://greymass.com/en/anchor/download

I haven’t yet, don’t know anything about Anchor but I will give it a go and let you know how it goes. Thanks for all your help. :grinning: With any luck, someone from metamask will actually reply to me soon…

1 Like