ETH lost in transfer// Showing as rejected

My account recently bugged out and .75 ETH has disappeared from my account. At around 8PM MT last night, I attempted to use my account to log into an NFT site to make a purchase. I transferred money from my an outside account into my MM but my wallet could not connect to the site, so out of precaution, I tried to push the money back into another wallet while I figured out why I couldn’t process transactions out of the Metamask account. The money would not transfer, so I tried to speed up the transaction. Now the money is completely gone from all my accounts and it is showing as rejected. I am hoping I did not just lose that money in a basic transaction with your app.

Welcome to the MetaMask Community @AGRIMM!! :fox_face: :rocket:

I apologize for the trouble with your transaction. For your privacy and security, and so we can investigate this further, I’ve created a support ticket for you.

Please reply to the email you receive with your public address and the txids.

Thank you for your patience.