Extra Stuck Pending Transactions - Stubborn

I tried to send some USDT from my MetaMask wallet to another MetaMask wallet address of mine.
I have 4 transactions queued for days. I troubled shot these things:
I started with the lowest CUSTOM NONCE number and tried to send another usdt transaction (with no amount) to clear the custom pending nonce with no luck.
I adjusted the Max base fee (GWEI) up multiple times well past 10% higher.
Same with the Priority Fee (GWEI) up multiple times well past 10% higher.
I closed MetaMask and reopened.
I ended up clearing the history data in settings > advance > Clear activity and nonce data.
I then tried to do a test send to see if all was ok but again ‘pending’. Grrrr

Any thoughts?
Im using latest chrome/windows 10.

Hi friend! Please have a go at the options shown in the following link: https://support.metamask.io/hc/en-us/articles/360015489251-How-to-speed-up-or-cancel-a-pending-transaction

Best regards


Firstly, Thanks for reaching out. I did both of your suggestions in the link you supplied… i forgot to say i tried this link and options in my original message. Im not able to now do any transactions in MetaMask… all transactions fail. This is very important. Do you have any other suggestions? Again…Thanks for reaching out.

Is there a way i can test my MetaMask wallet doing a transaction without paying the high gas fees at the moment?

1 Like

You can test by using another testnet network that is not congested atm, like Sepolia. Or other ones, like BNB testnet, Avalanche Fuji testnet, Polygong Mumbai, etc. You will need their native network coins to pay for fees there and ofc, you will need to add the networks in your MetaMask wallet.

Ethereum mainnet is congested and gas fees (gwei) are probably higher than what you used for your transactions. What 2Cu4 suggested is how to proceed with stuck or pending transactions.

If anything from what i said doesn’t work, it would be best if you contact Support team at https://support.metamask.io and click Start a Conversation


Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team directly.

Chat button is not working when i click on it. Im using chrome. I tried firefox but the same. See screenshot attached.
Is there another way i can talk to support?

I read several articles and clicked did not help. I waited for 1hr for the chat function to open but it is not working so i am not able to click on it to chat with support. Seems like the chat function is disabled. How can i chat to support about my MetaMask issue?

It was very busy over the weekend so queue times were longer than normal, can you try again please?

1 Like

The support chat feature is still not working. Can they turn it back on please.

It is on, what issue are you having? Can you send a screenshot?

Refer to the article @Chinzilla sent earlier:

Try on different browser, or on mobile, and see if any other application like adblocker is blocking it.


This topic was automatically closed after 30 days. New replies are no longer allowed.