Findora network unavailable

If I try to change from main network to Findora network, MetaMask gives me an error.
I used this Findora network before, and have sent coins to it, which I obviously can’t access now. Any ideas how I get my MetaMask connected to Findora network again?
Thanks in advance.

Hi @Wine87 and welcome to MetaMask community,

Just to double-check, I just swicthed my wallet to the Findora network and is working properly. Try to remove the network and then add it back again and see if that fixes it.


@Wine87 I’m not familiar with the chain but looking at their site and docs it also looks like you might need to bridge tokens from native Fidora network to the EVM network you’re wanting to use. See findora(dot)org (remove dots) at the bottom, you can read the dev docs as well as see the bridge option. Can’t vouch for any of this as I’m not familiar with the chain.

Thanks a lot @Urban.Moods
This worked perfectly and solved my problem.


Great :blush: happy to hear this! And thank you for taking the time to let us know it worked!


This topic was automatically closed after 30 days. New replies are no longer allowed.