I messed up and need help

is anything salvageable, am i overreacting or am I screwed, I sent Ethereum to metamask via BEP20 and it hasn’t arrived in about an hour
TXID: 0xbd1236118f7602375bd1bfc5f96fba75ea2a729306c3dd5799cca6067d6f8aed

Hi @ALiteralDog read this post :point_down: and please don’t curse :laughing:

1 Like

Hi i really need help its doing wird thing

I dont undestand what to do… I tried to connect metamask to trust wallet but it didnt see eth.
Before that i was sendit eth from trust wallet to metamask and i didnt see it, after that i correnct it by you recommendation on this webside … and i see ETH but its not possible to do anything

Hi @Alex5 especially you must not stress :grinning_face_with_smiling_eyes: Luigi is here


Problem is that you don’t have a BNB :slightly_smiling_face:
BNB is a transaction fee on the BSC network.

1 Like

I think that problem is that is not looking like ETH. I connect it with trust wallet but there is zero ETH . And its not possible to swap ETH to BNB. There will be other problem. Its possible that i made something bad. I send ETH from trust wallet. I didnt see ETH. I tryied to repair it. but its still not working, sending. swap…The only thing is that i am seeing it :smiley:

It’s Binance-Peg Ethereum Token :point_down: check your ETH address on this page

Transaction Hash:

And why i cant swap ETH to BNB?

Without BNB you can’t do transactions on the BSC network :slightly_smiling_face:

Send to ETH address: 0x722… some BNB.

Okay I will try it :wink: BNB Smart chain i sent it and I see zero. But when i go inside BNB i see 1,5 dolars … interesting. I am going for wine because i need it

Must work it :smiley: but be careful this is a BSC network NOT ethereum mainnet.

But i cant swich between ethereum site and BSC Maybe it will be the problem.

Try MetaMask :fox_face: wallet on the computer. Or restart your phone.