I'm not getting Trezor prompts, I can't sign transactions

To confirm a transaction on Metamask a window should open asking me to connect my Trezor, by typing my PIN and passphrase. Then I should be asked to confirm the transaction by signing on the hardware wallet. I’m not getting any of that.

Metamask acts as if had signed, and, obviously, the transaction doesn’t go through. If I move Metamask to another blockchain and come back to the initial one, the transaction appears as failed.

I’m using Google Chrome. I tried restarting the computer several times and also clearing my cache and I’m still having the same issue.

I have the latest Trezor firmware version and Trezor Suite works well, so it’s some Metamask issue.

I just tried reinstalling Metamask and I keep getting the same problem. A Trezor window opens and it instantly closes, I can’t sign anything.

Sometimes it works for a while and then I have the same problem again, a Trezor window opens and it instantly closes.

Hello @SATERABS, welcome to MetaMask community!

First, i would like to make sure you followed what this article points out as steps to connect Trezor to MetaMask.

Have you tried using another browser than Google Chrome? What version of Google Chrome do you currently have?

Yes, I did all that, that’s what needed to add addresses. The problem is that I’m not getting Metamask prompts for Trezor confirmations or they just close.

My Chrome version is 102.0.5005.115.

Found this topic about the same issue you are having. The thread started a bit more than a year ago, but comes close to this day the more you read. Hopefully there are some solutions in there for you to try out. Let me know if anything worked for you.

That’s what’s happening to me, but they don’t provide any solutions, other than moving to a different hardware wallet, which I would prefer not having to.

This keeps on getting worse and worse. I have to reset the computer several times just to sign a transaction. I guess Trezor just doesn’t work with Metamask.

Thank you for sharing this. Please also try to submit a ticket to our support team about it at https://metamask.zendesk.com/hc/en-us , by clicking “Start a Conversation”
support

Hopefully this will accelerate the process of finding a solution for you.
Also, at the same time, try to get in contact with Trezor support, to concurrently get the help you need.

I also opened a ticket before posting here. It wasn’t helpful. It seems like I have no other choice than to buy another hardware wallet, this issue has made me waste many hours already.

Really sorry to hear that. I hope your experience will become better in the future, and these issues won’t exist anymore.

I’m wasting so many hours because of this issue and no solution has been given after months.

I keep on having the same problem.

Let me try checking with Trezor team about your issue, to see if there’s any new possible solutions.

Hey @SATERABS.

Coming back to you with some inquires. Try and see if the following questions will get you some kind of a workaround, in the hopes of debugging the issue.

Do you get a similar experience if passphrases are turned off?
Are you using WebUSB or Trezor bridge? If the former, try having Trezor Suite running in the backend as the embedded version of Trezor Bridge is the latest version.

Also please check if this setting can provide you with a workaround, by disabling it for a test transaction:
Trezor Suite → Settings → Device → Safety check → Prompt

1 Like