Lost private key?

Hello people,
I use IOS/iphone/ and have metamask wallet. I have Seed Phrase.
I make Account 2/i dont know why :D/ and deposit BNB to adress from account 2.
Yesterday I see i can’t enter in my account, so I delete metamask app and try to enter with my seed phrase. I enter, but I dont see Account 2 :frowning: Can i restore it? I have money there.
I HAVE SEED PHRASE and PUBLIC KEY.

1 Like

same problem, i need the private keys which i didn’t save

I have the exact same issue. I somehow made two accounts. The seed phrase is working for the account that has zero coins but the seed phrase for the account with coins doesn’t work!
I tried emailing support but got no response.

2 Likes

Hi. I have exactly the same problem here. Is your problem resolved? Pls help me guys

La clave privada tienes de la cuenta dos ? si es asi solo tienes que poner en importar billetara, y si tienes la frase semilla que este vincualda a accoun 1 y 2 solo tienes que intalar de nuevo en un explorador con tu frase semilla y darle en crear cuenta 2 como ya esta en tu informacion se debe generar la dos con tus monedas. para terminar si checas en bcs o ther scan tu billetera si tiene ele dinero ?

Hi there,

I did the exact same thing. Have the 12 magic words but no private key. I have my public key and have hit the wall with what to do.

If you have made any progress with how you are getting on with this issue please let me know as have gone down the rabbit hole on trying to get it back.

With gratitude

DQ

1 Like

Me too. Did you make any progress?

Many thanks

DQ

1 Like

same problem, hope have solution soon!

No reply from Metamask Support. Just forget my balance and dont use metamask anymore! Hodl in TrustWallet!

1 Like

If you imported the account into MM, you’re out of luck, I think. But if you created them from within MM, they should be recoverable.

When you restore, you will only see your first account - but try clicking ‘add account’ and it should recreate accounts in the same way as it did previously, using the same derivation path. Please post here if that worked.

I have followed all the instructions they have sent. When I click add account, there are no other accounts there. I found my account on Etherscan. My question is when using github, it shows QR code and public key below, will the public key match the pubic key on Etherscan? This will help me tremendously if so, because then I can just such for it instead of trying to scan ever single one of the QR codes to find the correct one.

Sorry - not sure what you mean by “using github”? You mean using Dan Finlay’s mnemonic-account-generator there? If so, then I think the answer is yes: AFAIK, his account generator creates key pairs the same way that MM does. So if it appears there then it should eventually be generated by MM if you keep clicking “add account”.

Yes, Dan Finlay’s is what I meant. When I talked to support, they said not to chose generate 100 if I didn’t create 100 accounts… I tried 5 but none of the QR’s worked. I even tried 50 and none of them worked. I have the correct seed phrase but it pulls up an empty account. I have gone in and added accounts but they are all empty. One even has an error message saying it had trouble loading my tokens and to clink link to check balance. It takes me to ethplorer… which shows nothing… but I didn’t use ethplorer when I started account. I used etherscan, which does show my balance. Do you have any other tips on how to get my coins?

Screen Shot 2021-10-26 at 2.43.00 PM

So there are a few different issues here that we need to disentangle:

First and most basic question: do you have the public address for your old account? I presume yes, since you say you can see it on Etherscan.

Second, does the address still hold your tokens? Again, I presume yes, as you’ve checked on Etherscan.

Third, can you generate the address via Dan Finlay’s account generator? Generate a long list of account - not just 5 or 50 but thousands. Copy and paste that into excel and search for the public address that you know. If it is on the list then it will (or should…) eventually be generated by Metamask. If it is not on the list, then I can only suspect that your seed phrase is wrong; it needs to be EXACTLY correct. (An experts on derivation paths might be able to say if there could be another cause - I don’t think there should be for casual users.)

Fourth, if you can find the old address in Metamask, but the coins are still not showing, then it is usually a simple issue of your not having yet added the right chain or the token to Metamask, so the wallet doesn’t know what to do with the data. This is easy to fix: simplest way to add tokens is via Coingecko (clicking the metamask symbol next to a token and then ‘add to Metamask’).

1 Like

1-Yes
2-Yes
3- Okay, I will do this. Thanks again for your speedy responses. I will let you know how it goes.

1 Like

Update: hours waisted this morning.

Went to Dan Finlay, generated 1000 codes with seed phrase on a different computer. Nothing matched, so I went back to original computer, nothing… not even the empty accounts opened with the same seed phrase.
All public addresses start with: 0x
Not a single account generated started with an 0x… so I counted the digits. All accounts generated have 40 digits. The MetaMask public address have 42. Do I need to not count the 0x since in doesn’t exist on any generated accounts???

1 Like

Another Update:

took off the 0x and found 3 of the empty accounts.
Now searching for the one with tokens

1 Like