Lost private key help

About 1 year ago I bought a new phone and I had downloaded MetaMask on it because I factory restored my old phone that had my account logged in it. As I’ve entered my secret phase answers I’ve been logged in to a complete new address. How can I restore my tokens because there’s not much help about this situation and I notice a lot of people have had the same issue. I’ve tried all methods and nothing seems to work. Surely there’s a way to get your account back rather than it being completely lost. I have the contract adresss and everything but seems that you need the private key. I’ve tried importing my tokens and nothing shows up. I’ve tried making multiple accounts and nothing pops up. So please can somebody help me fix this.

1 Like

Hi friend!

It’s important to understand when using a seed phrase to restore your wallet, you will only restore the addresses that are connected to that specific seed phrase. If you have previously imported addresses that belongs to another seed phrase, then those will not show up.

Take a look here: https://support.metamask.io/hc/en-us/articles/360015489271-How-to-add-missing-accounts-after-restoring-with-Secret-Recovery-Phrase


If you have not imported any addresses, then the next step would be to get in touch with the MetaMask support team.

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.


This topic was automatically closed after 30 days. New replies are no longer allowed.