Restored my MetaMask wallet with seed phrase from trust wallet and lost all secondary accounts

Hi!

My MetaMask app was updated one month ago and I was logged out. When i tried to log in again I saw that all my secondary accounts was lost.
The account where I had my ONE tokens and Harmony mainnet is not an imported account as trust wallet doesn’t provide you with a private key in the app.

The only thing I have left is my public key and seed phrase but whatever I do dose not work. I tried to generate more than 60 accounts and I couldn’t see the account that I lost. When I applied my Seed phrase I got the main wallet that I had on trust wallet along with the Harmony mainnet as a network option and when I click on it I see that ONE token is there but the balance is zero and the address is not the same. The only address that is the same is the main account. But when I generate new accounts I never get the old one.

As I said before I have the public key and I can see my balance when I search my Cryptocom app to see the old ONE transactions that I send to my lost wallet.

I tried to generate my private key for my trust wallet even though I know that I didn’t import the account but the html link dose not work as I can’t chose ONE token there.

Please help!!! I tried everything and nothing works!

2 Likes

Good luck getting help on this. It has happened to so many people including myself. After the restore, your account number changed. Support is absolutely no help at all. I really do believe the restore is just MM way of stealing our tokens. I have been dealing with going back and forth with support and all they do is send generic responses. I know I put in the write seed phrase because I got a “congratulations”. I also put in the last word wrong another time and it said my phrase was wrong. Next, I noticed my account number had changed from my original account. I just want my old account back. The restore should have brought back the same account number. I believe they stole our coins. When I get enough money I am going to hire a lawyer and sue their asses. It’s going to be a class action lawsuit because they have done this to so many people.

3 Likes

I have the same problem too,and I try the way they published on support,and no luck for me.let me know if you get it back…

2 Likes

Hi I have the same problem now. Metamask is no help and they act like it’s not a problem. Have you figured it out? It has anyone?

1 Like

I got a wallet recovery company working on it right now,I will let you know how it turn out.

2 Likes

Hey @Hamdi, sorry to hear you are having trouble accessing your accounts. I have submitted a ticket to our support team for you and they will be with you as soon as they can. Please continue communication with us there.

If you are also interested, there is an active bug bounty for this issue: Metamask Security Advisory and Bug Bounty for Seed Phrase Concern | by Dan Finlay | MetaMask | Medium

1 Like