Matic Network, Have Matic, set slippage high still insufficient funds.. Nonce issue?

Had a transaction Fail on Matic (out of gas) and now I cant get past that last transaction.
Matic is visible on all protocols, The Nonce is being set to 75 automatically when Polyscan says I have 80 transactions. I set the Nonce to the last transaction which was the failed transaction #78, then 79 then 80-81 all failing bc of insuffient funds. I reset the wallet after and still the same issue

(set slippage and offered 20matic for gas still rejects. Dont even know what nonce to set since polyscan says 80 and yet shows 78 as being the last transaction (failed)

1 Like

Hey @sparkX, welcome to the MetaMask community! :fox_face:

Is your transaction pending or is it failed? If it is failed, then you should be able to continue forward with other transactions without having to cancel it.

If it is pending, please refer to this article on our Knowledge Base:

1 Like

SOLVED, RPC network. Go to the rpc settings and copy paste the rpc from the meta recommended rpc list.

1 Like