Metamask app freezes on my phone

I cannot do anything it freezes when opened.

hello, @Khasif24 Welcome to the Metamask community.
Are you still experiencing this issue? Have you had a chance to try reinstalling the app?

Hi… Reinstalled the app and it seems to be working.
Thanks

Hello. I have the same issue. Mm freezes. Anything i press takes forever. If it even does anything. Mm swap isnt working and mm wont function with uniswap. Not sure what to do. Please help.

1 Like

What version are you using? Does the reinstalling help?

hello, thank you for your response. I am using it on my iphone 12 (IOS 14.6). The Metamask version 2.5.0 is what I recently updated to.

I have not tried re-installing it. Will that delete my funds…? Do i then have to manually re-install all my coins?

I did try “resetting account” through the Advanced settings. That removed transaction history thinking that would help but it didn’t.

You funds stays in the wallet, reinstalling wouldn’t affect the balance of your wallet.
After reintstalling, you will have to add back any custom tokens or networks.

is it as simple as just deleting off my phone and just re-installing?

1 Like

Whats interesting is that over the weekend it let me swap usdc to another coin. This is the first successful swap in over 10 days. And after probably 100-150 attempts. That doesn’t sound normal. Right…?

Are you seeing any sort of error messages?

Yes, I get “unable to fetch quote” message.

This article will help explain what happened and what you can do when you experience this. https://metamask.zendesk.com/hc/en-us/articles/360060329612-Error-fetching-quote

I understand, however the issues I have been dealing with have occurred over 10 days. All my attempted swaps have been the most basic of tokens…USDC to ETH or visa versa. Same error message. Also, I have not been able to send my coins from metamask to another wallet. The app literally does nothing when I paste the other wallet address.

That does not sounds normal. Let’s look into this further. please open a support ticket here with necessary info and may a screen capture of what’s happening with the above issues you mentioned Submit a request – MetaMask
Be aware of scammers and not share your seed phrase-secret recovery phrase.

I already submitted request and have open tickets. I still have not recieved a substantive response. I provided very specific details on the exact coins I attempted to swap, screenshots of what I see when I try to swap, screen shot of error message that comes following attempted swap. Open tickets 213441 and 216272

Thank you for sharing your Support ticket numbers. I do see you have multiple tickets open with us regarding difficulties with Swapping. We do ask you to refrain from opening multiple tickets on the same issue kindly. It really slows us down from getting to your and others’ tickets in time. We appreciate your understanding and patience.

We’ve tested the USDC to ETH swap pair and weren’t able to reproduce the same issues. Are there other token pairs that you see this problem? Did reinstalling help to resolve it?

The issue concerning transferring tokens also seemed to involve the use of Uniswap, May I confirm you’re using the in-app browser from Metamask to visit Uniswap?

ok I will refrain from opening another ticket. I am just getting worried because I have been dealing with these issues for over 10 days now and still no resolution. The pairs were outlined in those other tickets in great detail. I assume you’re able to view them.

Uniswap was used successfully countless time BEFORE june 17th when these issues began. I used uniswap using apple browser, not the browser within metamask. I had no idea I could nor that I was suppose to.

Thank you, Alex. We do understand this can be frustrating.
Not sure how you were able to connect your MetaMask previously to Uniswap, WalletConnet maybe? They did have an outage recently. Try out the build in browser in MetaMask.

With the swap, I did went through the pairing you listed and wasn’t able to reproduce. Have you had a chance to reinstall and try the swap quotes again?

Yes I used walletconnet

Yes that can be an issue.