Metamask+ firefox+ trezor problem

I believe i am in the wrong forum but I cannot change the topic to backup/Restore/import which I guess is where it should be posted. can someone help?

Either way the problem I have is the following:

I have metamask installed on Firefox and to make things more secure I connected my trezor to the metamask and transferred my funds onto this Metamask+trezor wallet. I can still login and see the funds there, but when I try withdrawing the first error happens:

  1. Firefox freezes and the transaction never goes through. After that I cannot reopen metamask. I need to close firefox and then restart it to be allowed to login again but the transfer never got accepted.
  2. Normally that would not be a problem as I could just restore my metamask in a new browser. This works fine, but it only finds the metamask wallets not the metamask+trezor wallets. It seems like there is no way to restore the trezor wallets that actually have the funds on it through metamask, as when I connect trezor it just gives me empty wallets.
  3. Then I try restoring my trezor wallet in the trezor app with the seed I have, but it just returns empty wallets.
  4. I heard that maybe this is because it is in a so called hidden wallet (with the pw I used initially). I try restoring that but it only returns an empty wallet all the same.
  5. I tried getting the private key from the account from metamask, but unlike all the other accounts it doesn’t show up.
    So why can it be that despite having the seed and the passphrase I cannot restore my funds onto trezor? A solution to any of these problems with help me get the funds off and get rid of this nightmare. Please help :slight_smile:
1 Like

Your situation has been answered in other forums.

Hi - I have the same issue and its a pretty big deal.

I cant move any assets right now via MM and Trezor.

Please advise where the answer is in other forums, I have looked.

Also, this seems the same as issue 12967 on Github…

Please devs can we get some clarity on this issue?

Many thanks

This Metamask+trezor wallet is only associated with your trezor’s seed phrase and the passphrase you entered.
To gain control over the funds in this wallet, you must know what you entered in the pop-up window below when you created the wallet.

Yes, I have that phrase. It simply freezes after entering it… and no transaction goes through…

Hey Thank you so much - yes I was using the MM pass not the Trez one! Phew. Thanks gagin…


do you have a link to that? I searched the internet everywhere and couldn’t find anything…

I do know it, and when I enter it, it just gives me a new empy wallet. I tried in trezor bridge and trezor suite. Is there somewhere else I should enter it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.