MetaMask Mobile app bug after update - Cannot confirm signing

I missed out on some big money today because of some bug with the MetaMask mobile app. I updated the app yesterday or the day before yesterday, I don’t remember which day. I was going to mint a project today and when the pop up appears letting you know that you’re about initiate an action with the contract the “Confirm” button is useless.

You can click and wait forever, but it won’t actually sign the contract to perform the transaction. I’ve restarted my phone. Fully closed the app and reopened. Refreshed page of the project I was minting multiple times. Attempted to buy on secondary. None of these things worked. I couldn’t buy off secondary due to same issue.
Please let me know if there’s a fix or if others have reported.


The same thing happened to me. MetaMask updated today and confirm is useless. I tried multiple marketplaces, restarting app and iPad, and I cleared every browser history and cookies.


I am having the same issue


5 posts were merged into an existing topic: Link hardware wallet to MM

Hello and welcome to MetaMask community!

Thanks for reporting this, it’s a known issue and will be taken care of as soon as possible.


Do you know how long it’s going to take to fix this problem? I also have this problem with the confirm button on my mobile since Friday. Thanks :+1:


When will this be fixed?


It will be fixed soon, we’ll let you know as soon as there is an update!


It’s killin me man. Missing out on a lot of money.


Hi @Djsuperfresh
Try to open App Store/Google Play and see if you have the new version available: 5.11.0 and if it is available update the MetaMask app. The issue is fixed in the new version and I already have the update (iOS device).


I think you should go to a professional account manager and ask them to solve the problem for you

1 Like

The update just became available to me and it works now! Thanks!


Please I can’t sign in my account for days now have even uninstall the old MetaMask and download a new one and imported my phrase back but I can’t sign in transaction… Please what can be done have also cleared cache lot of times

1 Like

Hello @Slimice, welcome to MetaMask community!

Get in contact with our Support team at and click on Start a Conversation.
You will chat with a bot at first, but after a few question you’ll be able to get through to a Support agent.

1 Like

Of course, you are welcome :slight_smile: and thanks for taking the time to let us know it worked!


Anche a me oggi ha dato errore l’uso della chat.

1 Like