Metamask not adding custom coin CTI to Ethereum, but does add to BSC

Hello Metamask,
Metamask is not adding the custom coin CTI to my metamask wallet on Ethereum mainnet. When I click the button to add, just get a spinning symbol.

I can find the coin with my current balance on Etherscan. When I go to the ClinTex website and connect with my wallet, the ClinTex website finds my current balance. So, the coin does exist on the Ethereum mainnet and does have my correct balance. However I cannot do any transactions. Get only a spinning symbol when I click approve.

I was able to add the CTI coin to the same Metamask wallet using Binance Smart Chain network, so I do know how to add custom coins and my Metamask will add custom coins.

There seems to some problem with Metamask getting approval for CTI when I use the Ethereum mainnet. I do not seem to be able to do anything with my CTI balance on Ethereum.

I do have an ETH balance on the same Metamask wallet.

How can I get Metamask using Ethereum mainnet to approve my actions for CTI?

My Metamask wallet does not show the CTI

@Thony Thanks for your reply. I got your reply in my email, but I do not see your reply on the community metamask io site under my post. Where are the replies to the post?

I opened a problem ticket with Metamask. Metamask was not retrieving the values for my ETH either. I tested both with Edge and Chrome. Tested with and without Metamask Web 3 Legacy extension. Problem happened with all.

Testetd Metamask with Binance Smart Chain network with Ethereum Mainnet. Worked fine. Returned correct values for ETH and CTI. Would use this wallet, but the CTI website does not support Binance Chain Wallet.

Also tested with the same account with Binance Chain Wallet on Ethereum Mainnet. Worked fine.