MetaMask total fee .002, yet says I need 30 eth to complete

MetaMask gas fees normal, total transaction fee 30 eth when total is shown as .002. HELP ME PLEASE my assets are all stuck

2 Likes

Hey @MulletMajik, welcome to the MetaMask community! :fox_face:

The team is aware of this issue and is working on a fix at the moment. If you need to transfer your funds out right now, I would suggest using MetaMask extension.

1 Like

Well, shortly after that it worked again. Now, it’s doing it again. Are you guys aware of this?

Yes, the team is aware and working on it, thank you for your patience!

1 Like

Hy , i have exactly the same problem.
I cant buy anything from OS or another market place with the phone.
I cant swap on dextools or uniswap.
Can someone help me please?
I tried from pc , works because i can modify the gas,but when i try from the phone to modify the gas , they ask 20 - 30 eth to complete the transaction


@aDDICTED_the_DUDE you can reach out to MetaMask support through your app by going to the menu bar, clicking ‘support’, then choosing ‘Start a Conversation’. You also could visit support.metamask.io and click ‘Start a Conversation.’

@KBeeTheCapybara
Yeah except when you do that all you get is a robot that repeats the same 3 options. Never once directs you to actual human support.

@MulletMajik it does direct you to a human, there is a bot that asks a few questions first though.