Missing funds from Metmask - SELF transactions?

Hi.
Can someone please assist in clarifying on missing funds?
19 days ago i transferred 0.01971598 ETH ($90.76) minus 0.001575 ETH $7.25 in fees into metamask.
At that point i had 83.51 USD in balance.
I then had to pay another 0.002431513363 ETH ( $11.19 ) for approval DAI leaving me with a balance of $72.32.
Today i wanted to switch from DAI in Eth to DAI in Avalanche.
I can see a fee of 0.001873072558 ETH ( $8.62 ). In the metamask settings i edited the fees to only be accepted if around $10.
Then i see multiple fees again:
0.0013148059 ( $6.05)
0.001314217298 ( $6.05)
0.001320010399 ( $6.08)
0.001318412591 ( $ 6.07 )
All showing as SELF.
Overall Metamask too $24.25.
Thank you.

5 Likes

Why isn’t anyone answering tickets about missing funds? Why is Metamask ignoring these type of tickets?

10 Likes

Hey @element94, we’re definitely not ignoring you, just not able to respond to every topic right away.

Are you able to send a transaction hash to these SELF transactions? Are these fees, or are they transfers? If these are transfers to your own address that you have not done yourself, it may be that your wallet is compromised, but there would need to be more clarification.

1 Like

This is it:

It happened automatically when i switched DAI on eth to DAI on avalanche.

1 Like

These transactions may have automatically occurred because you tried to send DAI on Ethereum network to Avalanche network. Tokens are not able to be transferred directly from network, they must be bridged first.

Please refer to this article on our Knowledge Base, specifically point number 4:

1 Like

I actually used Avax bridge.

1 Like

No one has replied to my ticket.

missing-bnb-after-swapping-through-metamask-swap-function/9430/6
that is the topic that I posted.

I got an email from metamask checking if my issue is still active and I replied, but no answer.

I’m pretty sure they don’t really care.
I haven’t received any answer either. They probably ignore all tickets related to missing funds or unexplained transactions.

Hey @coldrein, your topic has been responded to. Apologies for the delay!

Hey @element94, if the transaction of DAI before your SELF transactions was through interacting with the AVAX bridge, the SELF transactions were likely automatically triggered from that transaction, as they all occurred at the same time. Because this issue is related to the AVAX bridge, I would suggest reaching out to the Avalanche team. Please make sure you were also interacting with a legitimate bridge to Avalanche network. Here is some more information that may help you:

The MetaMask team upholds user support as one of their highest priorities. We do not ignore any tickets relating to missing funds or unexplained transactions, and the team does their best to respond to all tickets in a timely manner.

Hi, I did not share my seed phrase to anyone. How come it was hacked?
Why was my thread closed?
Was the transaction hashes investigated?

Should I create a new wallet then?

Please read the article from the Knowledge Base I have linked in my previous response, and this will answer your questions. The thread was closed for your privacy and security, and to inform you that all communication should be continued with our support team after you have submitted a ticket.

I did that before but I did not get any response via email. What should I do then?

If you have already submitted a ticket to the support team regarding the same issue, please wait for them to respond to your ticket.

Hi. So i chatted with the guys from Avax. The response was the following:

“Hi, I have no idea what these SELF means, nobody else got that problem, try to reset metamask account : Settings>Advanced>Reset account, if it doesn’t work, try to clear your cache, or change browser, or use a desktop, have a nice day!”

Since both Metamask and Avax pass the responsibility from one to the other, maybe i should open a complaint with the BBB and Attorney General with both companies!

Could you share the transaction hash of these self transactions. Self transactions occur usually when trying to cancel a pending transaction. (Cancelling means replacing a pending tx with self tx with the same nonce value) This is just guessing from my part but it could be that you tried to cancel the transaction 4 times. It also could be something related to the gas fee you set, that it needs to be under $10. Ill investigate more when I get the tx hash.

1 Like

I haven’t tried to cancel the transaction.
This was a change of DAI eth to DAI on abav. All 4 happened at the same time of the change.

0x95a3f6d20bedee9ecfb236e557c5820708bd216c6d7d733b7b03480bcf144d2d

0xf018c2d63cc86c7856a370c2416a554aecc8e91b4caeb6793082db5ac317b1ee

0xc22a4680beb28275cbeadbb56497a24d3606b43ed6a111e764bf0862c191f8ca

0xe807b1ed757e84b8945be8d9fd5d87ea53226241856f76a45e2561d025063252

Andy Dollinger

Skype - dollinger.andy

These are definitely something related to the gas fee you set. They show different “confirmed within x amount of time”

  1. Confirmed within 04 days, 1 hr:38 mins:45 secs
  2. Confirmed within 04 days, 1 hr:38 mins:12 secs
  3. Confirmed within 04 days, 1 hr:28 mins:20 secs

Im assuming you did something 4 days prior that explains these. Did you change the maximum fee for the transaction 3 or 4 times?

The max fee that i set was around $10…I left it over night ( European night )… I wasn’t really hoping for it to pass taking into consideration how high the fees were at the time.
So not even sure HOW it passed.

Andy Dollinger

Skype - dollinger.andy

Well, it says these self transactions were confirmed within 4 days. So they were pending for all that time. Check the metamask log when the transaction was created and submitted, if it shows them