New wallet I didn’t make

I tried to pay for an NFT with ETH payment and now I have a new wallet with WETH payments and I can’t move it into my original wallet and I cant buy anything. So why didn’t my money go back into my original ETH wallet when that’s what I used as payment? can someone help me please. I can’t Bridge it, I can’t send it and I can’t swap it. This is so irritating :angry: so now what do I do? I can’t move it.

If you pay with ETH, then exchange WETH for eth,
If you want to transfer WETH to your old wallet, you can do it with “SEND” transfer in METAmask

I tried! It won’t let me it says I need Matic which I can’t convert it into Matic. So now what I sooo upset :angry: with this. If I tried to purchase something with one form of payment and it doesn’t go through I should receive same said payment back. But that’s not what happened and that’s why I’m mad :rage: at this whole thing.

You are using the Polygon network to pay for your purchase. Then, You need to have MATIC on this network to pay for the gas fees. If you transfer MATIC to Polygon chain in your wallet, the issue will be resolved.

I understand that but I didn’t want this account. When my purchase failed they magically added this account and put the ETH funds I tried to use in this account I didn’t ask for. So now I have to put money in this new account to get my money :man_facepalming:t5: My question is why didn’t it just go back in my original account.

The account wouldn’t have been added unless you had funds on the network.

Is the NFT you are trying to buy on Polygon? When you bought WETH to buy this, did you buy the WETH through the site the NFT is on?