NFT purchased on Open Sea not showing in MetaMask

Hello,

Yesterday, I purchased an NFT on Opensea via my MetaMask mobile browser and wallet. After purchasing the NFT, I transferred it from Opensea to my Metamask wallet ID (not sure if this step was overkill or not).

When I attempt to find the NFT collectible in my MetaMask wallet, I cannot see it. I also tried to add a collectible token in the wallet with the contract ID and token ID but receive an error saying “you do not own this collectible”.

Please advise. The NFT is visible in my Opensea account.

2 Likes

@pianoman101 Welcome to the MetaMask Community!! :fox_face: :rocket:

At this time, NFTs stored in a MetaMask wallet are not visible on the web browser extension. You can download the MetaMask mobile app and add your NFT under “collectibles.”

Each MetaMask wallet is device specific, so if you’ve added any custom tokens or RPC networks on your web browser extension, you will also need to add them to your mobile app.

You can read more about how to interact with sites such as OpenSea and add a NFT to your MetaMask wallet here.

Thanks for this information. I was using the mobile app and attempted to add the NFT under collectibles using the contract and token id, but receive an error message saying I do not own the collectible and it cannot be added.

I see the NFT in my Opensea account when connected to metamask so I’m still not sure why it says I don’t own the token.

Thanks

2 Likes

When you search for your address on Etherscan.io does your NFT appear? If so, sounds like there is a UI issue on our end. Please let us know so we can investigate further.

2 Likes

Hello,

I am having trouble deciphering the various contracts but maybe you can assist.

Below are my public metamask wallet ID, the NFT contract id, and the token ID.

After I purchased the NFT on Opensea, I saw it in my Opensea account and proceeded to use the Opensea “transfer” function. I paid gas fee and attempted to transfer to my metamask wallet but did not see anything appear in my metamask wallet. I still see the NFT in my open sea account

Thanks so much

@pianoman101 You can simply connect your MetaMask wallet to OpenSea and add your token. I suggest doing so on the mobile app, as NFTs/collectibles are not currently visible on the extension.

  1. Login to your MetaMask wallet on the mobile app
  2. From the in-app web browser, go to OpenSea
  3. Connect your MetaMask account to OpenSea
  4. Navigate back to your address/account in your MetaMask wallet
  5. Select Collectibles
  6. Select + Add Collectibles
  7. If your NFT is not automatically added, you can enter the address and token ID to do so.
1 Like

Hello,

I’ve tried the below steps but still see an error saying I do not own the collectible. If I can see the NFT in Opensea and it says “you” own the NFT, wouldn’t that mean I own it?

Not sure why I cannot add to my wallet.

Thanks,
Austin

After step 4 and before step 5, be sure you’re viewing the address/account on your MetaMask wallet that is associated with your NFT. You can view and toggle between your addresses/accounts by selecting the circle icon in the top right corner.

It’s a scam
Opensea owns the contract they use

Metamask says end of this year Opensea tokens should be viewable in your wallet

So you will not see in wallet anything

It only shows on Opensea

It will not show on other platforms

The erc 1155 token is pure scam

Useless

I’m gonna sue eth n Opensea over this scam

I created and transferred millions in 1/1 tokens in a new project I’m in

A big Fund bought all fifty 1/1 NFT’s for mega millions

I’m a famous artist in museums with very busy traffic on my site

I started to create and transfer them

The fund says not in wallet

They show only on Opensea

It’s 100% scam

I’m coming for you ethereum and Opensea

You conspired to deceive the world with etc 1155 nft crap

#openseascam
#ethereumscam

1 Like

Many people are having this issue. They own nft and can see it on opensea. When they try to add it to collectibles using contract address and ID it says they do not own it. So frustrating. Is there a fix for this?

2 Likes

Please note that while you can add NFT’s as custom tokens in the extension, you will not be able to see them natively in the UI.

MetaMask mobile displays NFT’s under Collectibles. Please remember that some NFT’s will not show up on the mobile app under Collectibles, or may not show up correctly.

We pull data from opensea.io, it’s our 3rd party repository for all NFTs. A collectible ID is a unique identifier since no two NFTs are alike. Please try finding the ID with the app where you purchased it.

NFT token 1155 is still in development.
You can still use platforms like Opensea and Rariable to interact with these NFT’s.

Hi there,

Thanks for the info.

Other people with NFT’s from the same collection can show them in their collectibles section. I used the Token ID from the app where i purchased the NFT (opensea) and Metamask says I don’t own it. Other collectibles that show in my metamask show alongside the new NFT in my opensea.

Not sure what else to try.

Thanks

Hi, I also have this problem and I did all the above, but unfortunately, it still gives the error that you are not the owner.

@Jebber @dramin. Can you two see the NFT in a block explorer like etherscan under your wallet address?

Hello! Have the same issue. Can’t add NFTs which is shown on OpenSea to my MetaMask wallet. There is solution to this problem?

1 Like

Ok. I have NFT in Rarible and I see it in Metamask wallet. The difference between NFT contracts in Etherscan in Rarible and Opensea is that in Rarible contracts are Verified (This is the message that is displayed: Contract Source Code Verified) but in Opensea contracts are not Verified (This is the message that is displayed: Are you the contract creator? Verify and Publish your contract source code today!).

Bought an NFT on July 18th. I bought it through the extension and when I did I originally saw it on Opensea. However, when I went to check yesterday, it was not in my mobile wallet nor even opensea as a transaction. I thought maybe I didn’t finalize the purchase or something but the etherscan confirms the transaction. Any ideas how to fix this? I reset both my wallets and reinstalled my mobile wallet but still nothing. Just bought a NFT on my mobile app and that one is in my wallet. Does that mean the previous one I purchased is in some weird metaverse I can’t get it out of?

1 Like

Jumping in on this question with same issue here, and to answer your question I do see the NFTs I’ve collected in etherscan under my wallet address yet cannot get them to appear in the wallet. Have attempted copy/paste of the contract address and ID many times over many days, with care, but always receiving the error You Are Not The Owner. Any help? It seems a number of us here have the same issue.

1 Like

Hello, I am having the same issue. I have tried the copy paste contract address and ID, only to get 'You are not the owner" even tho I am the owner when logged into OS. I have purchased some nfts via my mobile app and they are in my wallet. So strange. Thanks in advance

1 Like