The transaction cannot succeed due to error: undefined. This is probably an issue with one of the tokens you are swapping

I don’t know why it’s happens. If i want to do a swap in ethereum chain or BSC in all exchanges appears this comment: The transaction cannot succeed due to error: undefined. This is probably an issue with one of the tokens you are swapping.

I change my slippage tolerance, check if there are some transaccions pendings, when I want to do a trade I’m trying to not put a lot of decimals, I clean mi history search and put on controler gas in advance setting. I tried everything but isn’t work. My friend has metamask too and He can swap in this exchanges with any problem.

So for this reason I don’t know what can i do to solve my problem because i don’t wanna change my metamask just I want to use the same as always.


Hi, desniako

The reason is not for MetaMask Wallet, it’s slippage and commission for the transaction (Gwei)

what platform do you use?

If you send here screenshot I can help you more efficiently :slightly_smiling_face:

Bro I got the same error. Maybe you could help me.

I bought a token 3 hours ago on pancakeswap, but now that I want to seel it this message is what I get. I can still buy the token, but not sell it. I’d appreciate any advice you could give me. Thanks.
Contract address: 0x7cef5318dbfcca7f80ba7bf58511fc184f1b818f

I used uniswap for ethereum chain and pancakeswap for BSC, but in both pages i got the same error.
I can’t change gwei transaccion because when you wanna do the swap in metamask appears a small page in top right, but in my case this small page don’t work(for this error). So for this reason I’m confused so how to solve this problem.


In my case is in both. If i want exchange, sell or buy I can’t…

Mate. Firstly If you want to sell your token you should know what is the rule of coins or tokens for sale! For example, some token is not allowing you to sell or buy more and only you can buy or sell some percentage, If you showing here, what exactly you are selling that would be helpful

Secondly, you should have sufficient profits for selling, unfortunately, I do not see what token or coin you are trying to sell.

at the bottom of your screenshot is showing me that slippage is tolerance is 49%

did you change that tolerance or is it something that they want from you?

1- I need to know what is your token?
2- How much is the value for BNB?
3- Send me please screenshot of your setting which I mentioned?

Mate, Also, I need to see these steps …

1- What is the coin you want to buy? ADA? ( Take Screenshot )
2- Send me please screenshot of your setting which I mentioned?
3- I need to see details of swapping when you hit confirm, ( Take Screenshot )

Yes look, I bought this token called BOOTY CLUB with contract address 0x7cef5318dbfcca7f80ba7bf58511fc184f1b818f . Initially I bought 0.001 BNB and in a few hours I got abput 0.042 BNB so my profits were 42x times my initial buy. I saw some videos that said it was a problem of slippage tolerance so I changed it to the max that is 49%. Neither with 1% nor 49% of slippage tolerance I could sell the token.

Your problem is high slippage, if you put more for transactions which means will stuck!

put your slippage 12% your problem will solve I guess :ok_hand:

Bro I already tried with every number from 1% to 49%. I can’t sell the coin :confused:

Mate, this token looks like a dodgy token and you are in Trap! :hole: :boom:

It seems owner-locked for selling this token and only anyone who can buy it!

and I have checked there are no sellers at all until this time :robot:

All steps i usually do:

let’s try

Change your percentage to 12%, and you can swap I guess :ok_hand:

let me know if you done!

The error appears again…

Your BNB is not enough then, you need to have more BNB

all BNB you have is 4.97 USDT and is less for getting ADA and Transaction Fee & Slippage!

try for more BNB and your problem will fix

I have got the same issue and have rules out the following causes:

  1. caches have been deleted
  2. browsers and pc’s restarted
  3. everything is updated
  4. no pending tx’s
  5. vpn turned off
  6. not coin related, using pair bnb-busd

I have the same problem in Chrome and in Firefox, with 2 different wallets. Is this personal PC related? if so, please advice, the paranoia is getting real.