Transaction underpriced error using Arthera (new L1)

Hello everyone!

I’m working for a new L1 called Arthera: people can choose between the classic pay-as-you-go or a subscription plan. An app provider can subscribe his Solidity contract and then whitelist his users so they can interact with the contract paying even with a wallet that has a balance of 0 AA (the native currency of Arthera).

This works within Hardhat and with a Web3Auth integration too.

But MetaMask seems to be blocking: I’m getting a transaction underpriced error for some reason:

[ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“transaction underpriced”}}}’

In my code the gasLimit is forced to 100k:

await nft.safeMint(address, { gasLimit: 100000 })

Both the Max base fee and the Priority fee are set to 0, which might be causing the error, but that’s what I actually need.

Does anyone have an idea on how I should configure these transactions, please?

Hi @julienbrg what are you using for deploying could you share your config file please. Have you tried to modify the Max base fee and the Priority fee

1 Like

Thanks for your reply!

I can’t share links apparently so just add github . com in front of these links.

I used Hardhat to deploy this basic NFT contract. Here’s my Hardhat config file: w3hc/imnotlate-contracts/blob/main/hardhat.config.ts but there’s nothing special in it.

Have you tried to modify the Max base fee and the Priority fee

Yes I tried several ‘combinations’ as a user/tester. It seems like MetaMask (and/or ethjs-query) just won’t accept to broadcast the transaction at all. If some of you know what’s blocking that would already be great. :slightly_smiling_face:

The app is here: and that’s its source code: w3hc/imnotlate-ui/blob/main/src/pages/index.tsx#L1806

Thanks and sorry for the wait didn’t see your reply. Please refer to these issues:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.