Transactions keep failing with replacement transaction underpriced

I got a stuck transaction on OpenSea so I tried resetting my wallet. It seems to have worked, everything looks as before and I have a failed transaction when before there was a pending one. But now, everytime I try to buy something on OpenSea I get this error message

MetaMask - RPC Error: Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,“message”:“replacement transaction underpriced”}}’

Anybody knows how I can fix this?

Thanks

3 Likes

Hello! I have this same issue and also can’t figure it out

1 Like

What have you tried doing??

I have this exact error also. I have a stuck pending transaction while using the polygon bridge. I am assuming it did not have enough gas. The problem now is that I cannot do any other transactions or cancel that pending transaction. I instantly get this error. [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,“message”:“replacement transaction underpriced”}}’

I have tried sending a 0 balance transaction using the same transaction “NONCE” as the pending transaction but with a much much higher gwei and gas limit, I have also tried resetting metamask.

Nothing works.

1 Like

I had exactly the same error. Tried everything, resetting account, tried overwriting on mobile and different browsers and devices, nothing worked. Overwrite kept promting this same error. Stangely overwriting on Trustwallet app worked, so It definetely looks like a Metamask problem. Can metamask team look into this??

1 Like

I also notice it wasn’t possible to overwrite stuck transaction since the moment of ETH update… before it worked just fine

1 Like

I also have the same problem, has this been solved?

1 Like

I have the same problem. Tried the suggested solutions I could find but nothing worked. Ive tried with 3 different browsers.
Please Metamask team some help as this is very annoying.

1 Like

Yes, same error as mine. Hmmm. What can we do now?

1 Like

Hi everyone. Do you see a pending transaction on block explorer such as Etherscan?
r please open a support ticket via the support link on the MetaMask app or extension with info such as version number, transaction hash if you have.
Be aware of scammers and not share your seed phrase-secret recovery phrase.

Yes, have raised a ticket as have tried absolutely everything

In my case there was no pending transaction so I couldn’t raise a ticket and that’s why I wrote here. In my case I went away for the weekend, when I came back I realize the transactions that were stuck went through after a couple of days and now the problem is resolved and is not happening again. Relieved but pretty annoying error

Hi Isq, how do I get the priority of my Support ticket upgraded from Normal?

I would recommend increasing the gas price

Our team will be with you shortly. Thank you for your patience.

1 Like

I have the exact same problem. It looks there are too many of us to be a coincidence.
I would like to ask those who submitted a ticket, have you fixed this?

Also, how can we be sure this is not an OpenSea problem instead of a metamask problem? OpenSea has been having many glitches due to extreme load. Could it just be this, or is it definitely a Metamask problem?

Ticket 307913, im waiting for you guys to please check on this one. I cannot use it. Done increasing gas price and assign this to nonce 2 since its the one affected. Please

1 Like

You have older pending transactions in your queue. You will need to start from the oldest pending one.

Thanks @lsq correct. I have 3 pending transactions. Nonce 2,3,4

I already send 0 eth, choose a higher gas fee (high on the option when you edit gas fee) and assign nonce 2, but still getting this error

What should I do?

Are you not seeing the pending transactions on the MetaMask?
Did you reset you MetaMask account already? In the future please wait from support agents instruction before resetting MetaMask.

1 Like