Trezor transfer problem

So I recently connected my Trezor with my Metamask.
Unfortunately I am now unable to make transfers out of the hardware accounts
When i attempt a transfer, I get the error message that says, “transaction failed! signature doesn’t match the right address”
On the occasions that it doesn’t fail, it stays pending forever. When i go to etherscan to check pending transactions, it says “Invalid transaction hash entered: unidentified”
Instead of asking for my PIN, it sometimes asks for a passphrase. I did enter a passphrase (password) when i was setting up the account and that’s what i put when I am prompted. Still no luck.
I am using Metamask version 9.8.2

I am beginning to fear the worst. I need help!

1 Like

Im having the same issue, is there any workaround here? :frowning:

1 Like

was anyone able to find a solution?

Yeaa, I was able to get it resolved. Thanks for inquiring

2 Likes

Hi Cryptofun,

I´m with Gustavo and we´ are having a similiar problem. The error we get is “unknown address”.

The SLP was sent from Ronin to Ronin Bridge (0x121740ef14b0834c1d04cdb238ca740e27b17328)

For some reason, after the transaction opens in Metamask and I select “confirm” for the gas, I get the error described above (unknown address).

After some digging, I noticed bridge is connecting my Metamask to the following address for the gas payment: 0x1A2a1c938CE3eC39b6D47113c7955bAa9DD454F2

That number is different from the Ronin address the SLP was sent to, but that is what bridge is showing when it opens Metamask.

Could you share a little bit about how you solved your issue? If you have some time to reach out via discord it would be very helpful.

Thanks

1 Like

have you solved this problem, i have the issue!

I still haven’t

@Cryptofun , can you share your solution with us?

It turns out that my problem was due to the fact that when I was connecting my metamask to my trezor I set up a Password for “Hidden wallet”. So whenever I wanted to make transaction, it prompts me to put in that password. The issue was due to the fact that the original password I set up had a typo due to keyboard malfunction. I tried dozens of different variations of the password until I was lucky enough to guess the correct form of the password.
I don’t know if this is the same issue you guys are having but mine was an incorrect password error.
Hope this helps, let me know if you need more clarification