Tried to create a new account, existing account got duplicated instead

Hello all,
I have been using MM for some time, and have in the past (prior to last update) added new accounts, linked hardware wallets - all without any issues. This morning however I tried to add another account (clicked top right menu button, selected “Create Account”), but instead of a new account it created an exact duplicate entry of an existing account, which is same wallet id and everything. If you see the screenshot below (sanitised the amount of PLS but they are identical), I have selected Account 2 - and you can see both the original and duplicate are activated.

How do I get rid of the duplicate here? Recreating the wallet will be a huge PITA as I have a fairly chunky amount of imported coins that I’m tracking, so really want to avoid that.


Hello @Cratos, welcome to MetaMask community!

You can only remove imported accounts and external accounts that you imported with private keys or JSON (such as a hardware wallet).
Accounts that you’ve added using the ‘Create Account’ button in MetaMask cannot be removed. Only by restoring the wallet, which is the one thing you are not keen on doing and i understand. Or you can simply ignore it for now.


Thanks for your reply. So some additional details here, sorry for not providing; but the original “Account 2” is actually an imported account from a prior MetaMask on an old machine. I was trying to create a new account when the duplication was done instead (by clicking “+ Create account” button). So… if I can remove imported accounts, can I not simply remove this one, leaving my more important wallets intact? And how to do so? There is no “remove account” option that I can see.

And is this now my limit of accounts… so I cannot create new wallets, only duplicates, for example to do more xen mints?

Hey @Cratos, no the created account cannot be removed, only imported accounts can. Please refer to the article shared above for a workaround, and there is no limit to the number of accounts you can have

1 Like

My confusion mounts…
So I took the plunge and rebuilt, thinking I could get myself back up in a few days. Even after doing so, after I get into the main wallet, on a new installation when I create a wallet, it copies a preexisting one again. I also tried renaming on creating and I keep getting duplicates.

Is there some bug causing this? I never had this issue previously…

You mean duplicate accounts with the same address? If this is the case, please reach out to MetaMask Support.

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.