Trump trading card bug

There is a bug in MetaMask when a users tries to import the Trump Trading Card contract, it is detected as a personal wallet.

Hello @drwolf ! Welcome to MetaMask community !

I am not the owner of this NFT, but I tried to enter the contract address to emulate your error.
But the error does not occur, make sure the contract is correct,
if there are spaces at the end and beginning of the line:

0x24A11e702CD90f034Ea44FaF1e180C0C654AC5d9

7 Likes

Same exact problem.
I’ve tried to put a space before and after the contract like the guy who replied said but that doesn’t work either

He was saying to make sure you don’t have a space at the beginning and at the end of it.

2 Likes

Ok. Yeah I’ve done that also.

A definite bug on MetaMask

It’s not on MetaMask’s side, as i have no issue adding except that i don’t own any to be able to add it. I have the latest version of the MetaMask mobile app as well, make sure you updated your app and that you copy paste the address correctly.

4 Likes

It’s best you contact the Trump NFT team. However, make sure you’re contacting the legit support (there will be a lot of scam impersonators out there). Also, don’t share your Secret Recovery Phrase with ANYONE, even someone claiming to be support. Never input the Secret Recovery Phrase on a webiste, into a form, or into a pop-up window (no matter how legit it looks). MetaMask will never need you to re-verify your Secret Recovery Phrase once you’ve logged in. Also do not let support connect to your device.

2 Likes

Sorry but this is clearly a bug on metamasks end.

I will have to try it from a computer, maybe it’s a iPhone app only bug.

@Rory

What is your current version of the MetaMask mobile app and iOS ?

1 Like

This is a constant error and not only in adding tokens, but also in nft :slightly_frowning_face:

Hi @Rory and anyone else with same issue -

Have seen a lot of people get emails that share the incorrect token ID that was issued to them. Sorry if this is not the same issue. If you can duplicate, please contact our support desk at support.metamask.io and click the blue ‘start a conversation’ bubble. You’ll first have some automated questions to answer but then a ticket will be open.

Screenshots work great if you can provide them. Also please provide as many details as possible.

1 Like

Hey I finally figured out where to find the answer and it worked for me!

Basically inside the settings for your MetaMask to run on polygon there is a web address and that web address is the problem. Read this, I used the first one suggested instead! I was able to sell my Trump card for 5x what I paid (after fees).

Ok so I can’t post a link.

I’m going to share it on my Twitter account, Comicbooknftguy

1 Like