Unable to connect MetaMask wallet to Ledger

9.5.6 worked really well with the ledger app bridge that you put in place but it was removed in the 9.5.7 update. I now am again no longer able to transact using my ledger. My funds are yet again stuck, please we need some reliability in usage for ledger customers. Help!

I have problem when using Chrome91 too, Yesterday I connected my ledger through metamask and unable to transfer my tokens (ledger device did not react when I click send on Metamask interface), is my ledger compromised in this case?

Thanks for the link. This solution worked for me. After you install the older version of Brave and launch it for the first time, you can prevent Brave from auto-updating by renaming Autoupdate.app (e.g., Autoupdate.app.OLD) which is located in the Brave Browser application package contents. See screenshot:

2 Likes

When we could expect fix? I have been totally locked outta my funds and I need them ASAP

I am having the same problem. All my funds are locked. Is the is any update from metamask?

Thank you! I’ve been using Firefox for the past few days but this is a better solution!

No need to downgrade your browser, MetaMask already fixed this for Chrome, if you don’t see the option to enable LedgerLive in Settings > Advance, reinstalling the extension should get you the latest version.

Cheers :v:

9.5.7 is the latest version as of June 2, is it not?
This does not work with Ledger under Chrome 91.

Hope we can get an update from Metamask here…

MetaMask was working with Brave… UNTIL TODAY. Now it was “upgraded” to NOT WORKING. MetaMask Team: Please provide an update!

It works now! MetaMask has that advanced option to use with Ledger Live. That setup works great. Using latest version of Chrome too.

1 Like

Thankfully, I found this here before I went crazy trying to understand why my Metamask (Chrome Extension) transaction approvals were not being forwarded to my Ledger device for approval.

It did work for me when I tried the same Defi transaction on Firefox and the Metamask Extension for Firefox.

Wondering if such issues could be highlighted in the Metamask extension UI so that users are alerted to it without wasting too much time finding out the cause of the problem.

To resolve this U2F issue for Ledger devices on Chrome, you will need to update your Metamask Extension for Chrome to 9.5.8 and have Live Ledger installed.

To update Metamask to 9.5.8, in Chrome, click on the 3 vertical dots to access the Chrome Menu;

Select More Tools > Extensions
**Click the Developer Mode button on the right side of the header. **
**From there, you should see the Update button. **
Click Update and ALL your extensions would be updated.

Now go to Metamask, Settings >> Advanced and scroll to the bottom, you will see an option to enable Use Ledger Live, enable that.

The first time you create a transaction that requires your Ledger to sign or approve, Live Ledger will launch, you need to login and enable the Bridge. Once enabled, things would work as normal.

My tests on Uniswap, triggered a transaction for approval on my Ledger device, however, I can’t connect my Ledger on myetherwallet as part of my checks.

Hope this helps!

1 Like

I’m using Chrome Version 91.0.4472.77 (Official Build) (x86_64) and it works with Metamask 9.5.8, you have to go to Settings > Advance > Ledger Live… you need to have Ledger Live installed on your computer and configured with your Ledger.

I can confirm that does work with the 9.5.8 update to the extension, however, it seems to required opening the bridge once for every session. E.g. If you close Ledger Live, it will not work again. You must open Ledger Live and open the bridge connection, and leave it open, to execute more transactions in Metamask.

I hope this has some security benefit, because it is certainly a significant nuisance.

The Ledger Live option isn’t working for me. When I clicked “Connect Hardware Wallet” on MM, my Ledger keeps jumping out of the Ethereum opened mode, and then asks me to open the Ethereum app again. And this loop just keeps going. Looks like I have to use Firefox for MM from now on.

1 Like

Hey, if it helps I had the same issue. Restarting the browser and updating all the firmware and software worked for me. Are you still on the old version of brave/chrome as well?

I have the old version of Brave, which is working fine, and the new version of Chrome, which isn’t recognizing my Ledger.

@Ricchi and others, I’ve found a potential solution.

I was having the same issue where I had the ETH app open on the device, as Metamask says to do, prior to “Connecting a Hardware Wallet”

When I had the app open, and clicked, it kept going through to the JSON error.

Try backing out of the app on the device WHILE the connection is loading, this worked for me! Using Firefox for this.

I’m glad it worked for you! I never had problem with Firefox, but Firefox doesn’t support too many wallets besides MM, so I’m using the old Brave browser for other Chrome extension wallets. What a pain!

I have the same issue as ricchi. I have tried the three main browsers and nothing has worked. My issue with the Brave and Firefox browsers is that I can not update to the lates version of Meta Mask. Tells me I have version 9.5.5 and that this is the most up to date version. This mean I can not activate Ledger Live in advanced setting as it does not exist in this version. I have passed 24 hours without being able to manage me funds. I do this Full time need to resolve this urgently. Many Thanks.