Unable to connect MetaMask wallet to Ledger

I have the same issue. My fund is totally locked out. Please help

me too. I’ve been trying 3 browsers. All do not work.

Did you try clicking out of the Ethereum app while connected and buffering? Try following what I shared and let me know if still an issue.

I’ve mad some progress with the Brave browser today after the MetaMask updated to the latest version. I’ve followed this guide on the ledger website and connect to the bridge. Now my problem is that when I send the transaction I get a 77 Error. Any ideas what I do now?

my Ledger keeps jumping out of the Ethereum opened mode, and then asks me to open the Ethereum app again. And this loop just keeps going. Looks like I have to use Firefox for MM from now on.

I have a ledger live issue… keeps asking me to authorise to log in…
repeatedly… and nothing…
7 days and counting on not being able to access my funds…

Hello,
My coins are on Metamask and not stored on the Ledger, I am using the Ledger as another protecting layer, so I have to approve all my transactions with my Ledger,
I am using MetaMask Version 9.5.9 and Chrome version 91. I can make any transactions since we have the the issue with Chrome. I followed all the steps:

Metamask, Settings >> Advanced and scroll to the bottom, you will see an option to enable Use Ledger Live I enabled that.
When I try to make a transaction Live Ledger launched, and asked me to enable the Bridge when I try to approve it I am getting kicked out I see on the screen open Device bridge on top and open the Ethereum app on your device on the bottom, when I try to enable it it is trying to open device bridge and kicing me out again , I tried it over and over but I just can’t enable the Bridge .

Can you please help?

When you go to metamask, click on the coloured circle on the top right to show your list of accounts. Does the account in question have a HARDWARE tag next to it? If so, you are using a hardware wallet (Ledger device) with a hot wallet interface (metamask).

Your private keys and account are stored in your hardware wallet.

I am not an official representative of Metamask or Ledger. These are the two things I would suggest you do.

  1. Check that the firmware on your Ledger Device is running the latest version. If an update is available you will see it at the top of Live Ledger.

  2. If it still doesn’t work. Reinstall Live Ledger

  3. The last thing you can do, is to obtain the seed phrase from Metamask for that account, and important them into another browser that has metamask extension installed. This would effectively move the private keys out of the Ledger device and you can manage that account. DO bear in mind the risk of using solely a hot wallet.

The above are just my advise, you will need to do your own research. All the best.

I’m having the exact same issue. Same version of MetaMask (9.5.9), although I’m on the Brave Browser (Version 1.24.82 Chromium: 90.0.4430.93)

Device bridge on Ledger Desktop launches, but every 5 seconds I’m asked to “open app Ethereum” by the Device Bridge, referring to the ETH app on the Ledger. I click both buttons to approve, and the scenario repeats.

Not really looking for a solution that involves using Firefox. Don’t want to move Metamask again. Is this something that Ledger needs to address since it involves Ledger Live, or Metamask needs to fix?

Just want to report that I stopped having the Ledger Live problem about two days ago. It just worked all by itself. I transacted today with MM on Chrome and everything was fine. Thanks for the fix, MM!

Congrats ricchi. I still haven’t been able to solve this issue, using Metamask on Chrome, having upgraded my metamask extension to the latest version (9.5.9), have the Ledger Live desktop app open and connected to my Nano S, and activated the Úse Ledger Live’ option in the Advanced menu option on my Metamask wallet. Is anyone still having the same issue, or is there any key step I am still missing? Many thanks for any advice

I don’t remember what I did, but try this:
Restart the process. After you open Ledger Live, click “Manager”. Once you see the installed applications, click “Accounts”, and try to open the bridge or the Ethereum app from the Accounts page rather than the Manager page.
Don’t know if this will work but I remember my problems happened on the Manager page.

Thanks ricchi. I went for the alternative option of installing a Firefox browser, and there were no problems at all, the ledger is now working fine.

On MSEdge, I cannot connect ledger nano x to metamask

Tried Brave Version 1.24.86 Chromium: 90.0.4430.212 and Chrome Version 91.0.4472.77. Extracting LP from contracts is impossible, can’t claim anything let alone remove liquidity. Even simple swaps on UNI or no good. Can you at least provide a short demo or step-by-step of how to perform the tasks. I’ve got it all up to the point where LL opens, I allow for WebSocket access the bridge initiates then the tx is stuck, and never goes through. I’m using the latest firmwire 2.0 on my ledger. Can we get a little more support here

I’m not sure if my problem is the same as this, but I cannot get Metamask to connect at all with my ledger.

I have tried the most up to date versions of 4 browsers: Chrome, Edge, Firefox, and Brave and their respective Metamask versions (9.5.9, 9.5.4, 9.5.5, and 9.5.9). I continously have the same problem where when I click on connect to Ledger, I have a orange spinning wheel/circle that never stops with “Looking for your ledger…”.

I have my Ledger Nano X (Firmware 1.3) on the up to date ethereum app open and unlocked. It connects with my Ledger Live and my Windows 10 computer just fine. Firewall is off.

When I try the connect to Ledger Live method on Brave + Chrome, even clicking the on/off switch causes the spinning wheel that never stops. When I try the bridge method of just typing into the browser itself, my Ledger Live responds to that, but it does not actually connect with Metamask (ledgerlive://bridge?appName=Ethereum).

Most irritating of all, and I’m not sure if its related, is that when I try the Crypto Wallets area of the Brave Wallet, even that does not connect to my Ledger. So I am not sure if this is a Ledger problem or a Metamask problem, but I believe it must be Metamask because just clicking on/off for Ledger Live under Advanced creates this problem. And it happens regardless of browser as well (Firefox, etc).

Please help.

Hey all, I fixed the issue after looking at old websites with similar problems.

I use noscript on all my browsers, and that is why this happen. I disabled all my extensions aside from Metamask and it worked on Brave. Best of luck to all.

Same issues:

  1. Can’t connect my Ledger in Brave (“Internal JSON-RPC error.”)
  2. Can’t use Ledger in Chrome (nothing happens on transaction confirmation)
  3. Can’t use Ledger in Firefox (nothing happens on transaction confirmation)

This should be urgently resolved since funds are getting locked.

FYI all in the same situation as me:
(I’m using Ubuntu and tried Brave, Chrome, Firefox, Opera even, but nothing works…)

“The workaround implemented by MetaMask doesn’t work for users on Linux. We are currently working on a fix which will be communicated soon.”
support ledger com
/hc/en-us/articles/360020871157-Connection-issues-with-MetaMask-

hi Support, your workaround for Mac still does not work !!

last version everywhere, I manage to display the bridge window on Ledger Live, but then nothing happen when I try to submit a transaction… please give us some news !

Anybody made this work on Mac ? thanks

2 Likes