Unable to load NFT in MM mobile

I have developed a smartcontract for NFT and deployed it both on rinkeby (for testing) and mainnet. I’m able to see tokens minted on both chains via Opensea (and Opensea testnets) and Rarible and I’m also able to import them into other wallet managers, but when I try to import any token in MM mobile, the import screen closes without any message and the tokens are not added to the gallery: no error message is displayed, the NFT import screen simply closes apparently doing nothing.
Even more concerning is the very same token is imported correctly if I switch MM mobile to operate on the rinkeby network!

If you wish to inspect the contract or one of the tokens here is the tx hash on mainnet for a token transfer on Opensea: 0xed7c30065c8af5d7134d485cf3ac0bb442473d5f75512ed92cce574412421099. As you can see contract is verified on Etherscan.

Am I missing something? Why the exact same token is imported smoothly on rinkeby and fails on mainnet? Does MM mobile perform some additional check on mainnet that it doesn’t on rinkeby?

I’ve tried contacting MM support, but I got no answer… I’m out of options and ideas.

Hey @rlogiacco, welcome to the MetaMask community! :fox_face:

NFTs are currently not available for display on MetaMask extension, but it is in the works! It is only available on MetaMask Mobile at the moment.

Here is more information on our Knowledge Base:

1 Like

I’m aware of that, that’s why I clarified the issue is in MM mobile

My MM mobile version is 3.8.0 (801) on iOS 14.5.1

What do you mean with “have you Migrate your wallet”? My wallet uses an imported private key, but, as I said, the exact same address works perfectly on rinkeby…

And what that mean? No, I don’t know what you mean with Migrate wallet, can you please elaborate?

Not sure why it’s closing out like that when you try to import, have you tried resetting your wallet?

Here is more information on our Knowledge Base:

Thanks a lot, but I hardly believe this is going to be a solution: practically anyone having acquired one of such token (over 4000 distributed) is experiencing the very same issue with MM mobile.

If you would like, you can submit a ticket to the support team at https://metamask.zendesk.com/hc/en-us and click Start a conversation

I’ve done that 4 weeks ago: still not a single answer from them and 4000 “customers” complaining :frowning:

Sorry to hear about the wait, I have just informed the support team and they should be with you as soon as they can.

Thanks, I’ll crosslink this conversation to avoid the same questions and suggestions.

1 Like

@nakedwinnie I guess this is another scammer and not you, am I right?

Correct, this is a SCAM :imp:

I will only contact you on community.metamask.io and will never ask you to message me on Telegram.

I received a response from MM support: create an issue on Github… honestly lads, this is drifting into the edge of reality dimension…

I have more faith in someone over here standing up rather than anywhere else.

This topic was automatically closed after 30 days. New replies are no longer allowed.