Unable to recover funds

Hi,

I’m unable to find my tokens after restoring MM on my laptop.

Seed phrase, private key ok. network ok.

When i import the token contract, they display with an error message saying: “we had trouble loading your token balances. You can view them here” click on here then redirect to a eth scan while my token are on bsc.

When i check the address on bscscan, also, no track.

I don’t know what to do now, did someone experience the same issue?

Looking forward to your help

Thank you

Please make sure you have inputted the correct seed phrase for your MetaMask wallet and it is configured for the BSC network. Since the address shows that there are no tokens on bscscan, it is likely the incorrect address you are trying to access.

Please also refer to this article on our Knowledge Base for errors loading balances:

2 Likes

After trying several times your recommendations, I still not succeed to restore the accounts. I tried to add them as suggested in the link you’ve sent but still doesn’t work.

Please assist

Did you ever get help with your problem?

I did receive an inbox message from moderator 1 month later, asking more details about the issue (with specs of my computer etc.)

Still ongoing process, will let you know if positive outcome.

Is your Account Address the same as before ?
If you had multiple Wallets in your metamask you need to manually add them again

1 Like

Thanks for getting back to me. It really is appreciated. I have to say, so far MM 's customer service could use some improvement…to say the least.

1 Like

Hey @Tronsky, if there is an issue you need help with, please create a new topic :slight_smile: