Restoring wallet, add tokens but balance showing is 0 but contradicts etherscan

Hi,
Feel like I’m missing something and feel stupid, can see my coins on etherscan but can’t seem to get visibility/access in metamask which is/was were they were held. There seems to be a lot of content on these type of issues which I’ve tried but with no success.

Have re-installed metamask, re-entered my seed phrase + provided new password, added the AGI (through adding custom token using 0x8eb24319393716668d768dcec29356ae9cffe285) token but my tokens aren’t there (balance shows 0). From all the self help they should be visible.

Which leads me to try to ‘Import wallet’ then when private key is requested put in my seed phrase but then get the following error ‘Cannot convert string to buffer. toBugger only supports 0x-prefixed hex strings and the string was given: 0x******’. (****** = repeats my seed phrase).

Is anyone able to assist, just don’t know what else to try or if the tokens are gone for good.

Hope someone can help?

More people have problems after instal new metamask wallet.
First… Is the wallet address main eth account still the same as before.
I have after new instal and installed imported accounts with key and now showing two different adres then I had before.
Option for you to try also… At a new account.
Maby the tokens are in account 2!

Hi,
It’s different, have added 4 accounts now but not matching the original. Is there anywhere this data can be inputted manually?
Is there something I’m missing to get it to sync - the tokens I’m adding are AGI which now has to be added as a custom token - don’t know if that makes things different - doubt it but worth a mention at this stage.

All the same over here… My seed phrase is 1000000% the right one.
But still get a total different adres as main wallet.
The inported accounts also.
I am in crypto for a will so I don’t make mistakes any more.
This must be a mistake in network from metamask.

Don’t know what I’ve done but tried this same process on my phone (app was only installed on laptop), added custom token and it was there.
Mixed feelings, glad it’s resolved but sad that I can’t be of more use to others.

Can u please contact me on twitter @Lukete23088814, This is for sure a Metamask problem, i wrote my phrase down 10 times! Got a new adres? On etherscan my old adres still exist with all my money on it. I am not hacked, never shared personal stuff with anyone, METAMASK rewrote my adress idk or it is a bug or some but it has to be fixed!

1 Like

I wait a view days more for help desk support.
So far no luck.

Any updates on your problem? I have a similar problem. I thought everything will be okay when you imported the seed phrase into your Metamask. Etherscan doesn’t have anything too. My account 2 is not there also. Tried adding the tokens but it has zero balance. I hope they can do something about it because those are hard-earned money. I really like using metamask tho, This is the first time I’ve encountered a problem. I hope they can do anything about it because I need those lost funds/tokens.