Vault Decrypt - Some Tips

So besides not giving anyone access to your passwords or seed phrase, there are several things you should know about Metamask in case you did not keep a copy of your seed phrase.

If you simply created a new wallet with a new pass phrase, the information about your vault data will still be available for a while for the older addresses, just for a while, so better backup that file before closing the session and so on). Just use the Vault Decrypt and the passwords you employed. It is strongly recommended using Vault Decrypt in a local computer not connected to the Internet to be safe.

In some cases, if the Chrome Plugin is uninstalled and you did not save a copy of the folder that contains the logs, you may have lost all hope (unless you have a restore point before the changes and you copy that data of the plugin folder, usually something like this in Windows:

"C:\Users\_xxx_Replace_With_User_Profile_xxx_\AppData\Local\Google\Chrome\User Data\Default\Local Extension Settings\nkbihfbeogaeaoehlefnkodbefgpgknn"

Other browsers, like Brave are, in my opinion less reliable but the folder structure is the same for plugins like Chrome.

Remember to always keep your seed phrase safe or at least the private key of the address you use and care about.

One more thing, don’t trust people who tell you that they can help you, if it is doable you can do it alone most of the time, if you can not do it, it means there are no chances of recovery (and that is the beauty of Cryptography applied to Finances, only the holder of the private keys controls the wealth.

5 Likes

Lost my seed key have password but scared to delete app on iPhone with no seed key cant get in data corruption

1 Like

Looks like my coins are gone :sob:

If you have access to your address in Metamask in your iPhone or other devices you can “Reveal Secret Recovery Phrase” if it is the main account, if it was imported, just go to “show private key” in Security and Privacy and nothing is lost. Make a good copy of that private key and funds will be safe for ever as long as no one else has access to that private key.

1 Like

Had a message saying data corruption now will not let me log in with passwords now ask me to download again and use pass key

Do not do anything else. Try to make a copy of the raw data that is inside your iPhone and try with that data in a computer to locate your Vault data (it is a JSON file) and decrypt it with your password. The less you do, the better.

To late :sob:tried to reinstall to see if it would help that’s a no :sob: but the wallet is still linking to my wallet in my phone browser in uniswap but that all I can do see the will no link to my wallet

Have password and know address is there anything I can do also is still linked in my iPhone browser to uniswap but will not link to wallet

Are you aware of any ways to verify the vault data format/ is there any public documentation on the contents of the ldb json file? Getting different responses in the Vault decryptor (‘Problem decoding vault’ error warning vs. no change) for trial wallet vault data extracted from the browser console with an incorrect password than that for suspected vault data extracted from the original ldb file. As an aside, i’ve identified five identical instances of the vault data in the ldb file so interested to understand more about what they correspond to.

Can you help me
I never backed up my seed phrase anf IPFS went down, I changed my password and account has 0 in it. No transaction no funds.
Im using Iphone.
How do I recover seed phrase from mobile app?
Mobile Metamask is in my phone still.
I never had the extension.
I have my contract addresses .
Have not received any response from Metamask yet

With the information you have provided seems you can still access your Metamask in your iPhone so you just need to go to “settings” and reveal the seed phrase and store it in a safe place and never, ever, share it with anyone through the internet or even Metamask support, they will never ask you for that.

If you can not access for some reason just elaborate here to help you further.

Just removing the back slashes should do the trick.

I tried clicking reveal phrase using old and new password its not working, gives me a message Can’t unlock the account when I enter password to reveal phrase.Its hard since its mobile metamask they dont have more info on it .I did back up the phone and was able to reach persist.root .
When I extracted vault data to decryptor , it didn’t return any result( after removing /// and making changes as described). Im waiting desperately on support to respond.

Any idea if the seed will be there even if I clicked remind me later for that?

Appreciate your reply and looking forward to help.

Thank you

Hi okeygo
Hi all

I have a big problem, I have meta mask only on my Iphone 11 pro (not on my Mac or PC).
Until now I have opened the meta mask on my iphone by Face ID or Password.
Since a few days, the Meta Mask App to not open by Face ID & Password, because there is an storage limit error.

The best point, I do not have/lost the seed phrase.
I made a back up on my Mac from Meta Mask, have also the JSON file, but do not know how to countinue.

Very appriciate your reply and looking forward for help - thank you very much.

Hi everyone, I was reading all your writing above, hoping you solve the problem… I’m having similar problems IPFS is down on Eth, BSC networks and I’m not able to send or exchange my coins. Seems like it’s problem in BSC network in my limited opinion, when I go to BSCscan to check my account I can see 7 tokens which I don’t have in my wallet and all of them are flagged for scam/malware and I don’t know what to do with this still have access to my account and any of my coins at this point didn’t been moved anywhere, but it seems like I’m on a good way to bee scammed​:pensive::nauseated_face:

As long as you do not interact with those free tokens you are safe. Most of them, if not all, are leading you to malicious websites that try to steal your credentials and then move whatever you have.

Never go to websites you do not trust, check before clicking and never approve a contract of an airdrop you did not participate in.

Good luck

Once you have the right JSON file, find a computer not connected to the internet to use the Github of Metamask with the Vault Decrypt code using your password.

You may need to remove backlashes and so on, just check the documentation that they do offer. It will help you further in the future to know how does Metamask store your data.

Good luck

Hi okeygo

Thank you very much for your support, it helps a lot.
Is is very friendly from you to do this.

Checked many times the documentation from you and Randy template in this community - Vault Extraction Instructions for Mobile iOS.

After search for the word “KeyringController” in the JSON file. Find this word, but the JSON object do not look similar like the documentation,
Did I make something wrong or do have to check elsewhere.

Sorry, I had now a lot of sleepless night to try to understand all this.

Thank you for your help, it is very friendly from you, that you support us all here.

Best Regards
Faton

I am in a similar situation (ios, storage issue, vault corrupted, etc).

I tried extracting the vault data from the app via Imazing as Randy instructed.

It did not work for me because the persist-root file did not contain the word cipher.

I know my MM password, but I cannot seem to get into the vault.

Any advice would be appreciated.

Can you instruct me how to extract JSON object in persist-root file?
If there is a video tutorial, even better.
I will appreciate it very much.