Warning „not enough eth“

If a user does not have enough ETH for the maximum possible gas fee, proceeding with the transaction is blocked by a warning. The possible adjustment of the gas settings would only be possible in the subsequent step, but is already blocked by the warning.

Suggestion 1: Allows the gas settings to be adjusted before the transaction is blocked by the “not enough ETH” warning.

Suggestion 2: Give the user a warning that the transaction might fail, but let the user continue if he wants to take the risk. The bottom line is that the user should decide what to do with their assets. (e.g. if the user does not want to top up ETH and wants to try his luck with the transaction).

As background info: I, and probably some more, use a service provider that puts the transaction on hold and only sends it out when the gas parameters I have defined (eg base fee = 30 gwei) are reached. so I can send transactions when the fees are high without them failing. However, MetaMask does not allow the transaction to continue because it already blocks the continuation of the transaction beforehand by means of the warning.


  1. The adjusted gas settings may result in a lower maximum fee that might be covered by the
    available ETH.
  2. Let the user decide if he wants to risk a failed transaction or not. It is good to warn the user, but not good to block the user. The user risks his own assets, if he wants to risk it, let him risk it.