XLON token wrong wallet balance + token gone from swap button (workaround)

Does anyone know what’s going on with the XLON Mars token?

contract: 0x36ff4DaE0E88113D68B1209e245B0e3Af92E9D58

My wallet balance shows as 10^12 (12 extra zeros) more then my true holdings AND the calculated fiat balance of several billion dollars :joy: is not added to the portfolio total.

I tried adding the contract manually to but I’m not able to adjust the token decimals which is fixed at 6.

Also, I was not able to swap XLON through the swap button without doing a bit of a dance. It worked fine last week.

To get it to work I had to click through to my XLON portfolio, then click swap, then select “to ETH” then click the double arrows to swap the to/from tokens and only then could I do the swap (with the number of tokens to receive off by 10^12). Just searching for XLON did not work. This was at https://portfolio.metamask.io/swap instead of the plugin if it makes a difference since I find it easier to read.

After doing this XLON appeared on the swap menu for a while but now its gone again.

Is there some way to fix XLON so it displays and swaps properly?

1 Like

hi @Geoff ,welcome to MetaMask community.
I can add the contract address you said normally, and I searched the contract you mentioned on geckoterminal . com (It is a subsite of coingecko) , its trading volume and liquidity are not very high :joy:, so you may not get the swap amount you expect.


Thanks for looking at this @tuya I was able to swap successfully and it went through right away, so my problem now is just that the XLON balance is crazy high and doesn’t get added to the portfolio value :grimacing:


Apparently XLON could be the next PEPE!


hi , try to import token here to see if it works


I added the token but as you can see it shows as several billion dollars balance and tokens are off by magnitude 10^12 :joy:

Unbelievable, you have so much …
It may directly use price x amount to calculate the balance. since liquidity has an impact on real value, so it might not be accurate . ( just my personal guess :joy_cat:)

1 Like

Yes it would be nice!

the balance is supposed to be: 565474276
So MetaMask balance is exactly correct, except that amount has 12 zeros too many after it! I was able to confirm this on block explorer. Strange huh? All my other tokens are correct

This topic was automatically closed after 30 days. New replies are no longer allowed.