Accessing lost MM account (reward)


please help me reach my lost wallet. If we are successful, I will reward you in USDC or any other common crypto. I know I have made many mistakes in this story, please don’t punish my conscience more than it already is.

So it was like this: I have been using MM wallet, didnt write down seed phrase. A friend of mine wanted to help quickly, but his browser was bugged or something, so the quickiest solution was to give me his seed phrase over an encrypted channel, in order for me to be able to “recover” his account and do transactions he wanted. Meanwhile I didn’t know how to add second account/wallet, so I removed my wallet - yes, this was the biggiest mistake. I’ve tried common methods of recovering vault, but it seems that my wallet is not there. I’ve been able to find 2 private keys in there from my earlier experiments, but not the one I have been using lately (my friend’s wallet, which I have already deleted, is not there either). I have neither uninstalled the MM Chrome extension, nor the browser itself.

A strange thing is, I have been able to decrypt a file with a name “010089.log” - not ldb, but file “000005.ldb” couldn’t be decrypted using MetaMask Vault Decryptor. Manually opened I wasn’t able to read anything, many of the characters seems corrupted (image).

What I have:

  • public key (address)
  • password to the lost MM account
  • the computer where the MM account was lost

What I don’t have:

  • seed phrase
  • private key

Is there any chance of recovering this account? I’ve been accumulating savings during college there :frowning: .

Thank you for replies.

Hello @sad-boy only option I can think :neutral_face: try some data recovery software.
Preferably some portable program :computer: which you download to USB.
Recuva Portable, Disk Drill or something similar.


Hello Luigi,
thank you for the reply.
I have already tried this option. I’ve been able to dig 3 files, but their names are “009484.ldb”, “009941.ldb” and “010088.ldb”. As none of them has 0 five times followed by a single number, i considered the results irrelevant.

@sad-boy check all the .ldb files you found :slightly_smiling_face: sometimes the number can be large


I have done that. No success. :frowning:

It is a pity :slightly_frowning_face: probably the data is in another file that you did not find. Data recovery is complicated, especially if you use an SSD disk.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.