Can see account can't access it. I removed Metamask from Extension (Chrome) by mistake

I installed MM again with Phrase, My Account wasn’t there. I tried to import by private key MM said not right, just mathematical statement… I then used watch facility on MM, so I can now see my tokens. I have been waiting now for two weeks for MM to get back to me, so far no one has. I have read a lot, my conclusion. Until MM provides an exact solution I am concerned I will loose all. On one conversation there were a huge amount of people having same problem. I’m under an assuption there is a reward, if we as MM users can prove we had the correct words in the right order, well I believe I am one of those. I was very particular about saving my seed phrase. Where is the support? I know MM make a small fee every time we buy, sell or swap so why isn’t MM being pro active. Can we have support please MM.

Was the account that had your funds a secondary account created in your MM wallet? Or, was it an imported account (you imported the private key or JSON file from another account).

If it was a secondary account, you can choose to “add account” or “create account” on your drop down and it will always restore accounts in the same order they were in.

See more here:

If it was imported, this will not apply. Check out this article which may help explain further:

1 Like

Hello thanks for the quick reply. I accidentally removed MM from Chrome extension. I then re-installed MM with 12 word phrase. I got new wallet with 0 in it. I then did research. Research said it may be I had an account with 0 in it, MM won’t go past the 0 account.
So I went to add account, the MM account I had before. So I went to “IMPORT” so I tried my private key, that is a MM account allocated by MM. so each time I did that I got This is not a valid private key. You have entered a hexadecimal string, but it must be 64 characters long.
So MM said I can watch an account. I put in my private key in and added, presto my account was there. However, I can’t access says to re-install MM again. I fear that if I do that I will be further behind the eight ball

Hey! Did this ger resolved?

If not, can you please reach out to our helpdesk so they can help look deeper into this: and click the blue ‘Start a Conversation’ button. The bot will ask a few questions to help get you routed to the correct team in support.

This topic was automatically closed after 30 days. New replies are no longer allowed.