Eth to Ronin transaction changed to Ronin CONTRACT address

I submitted transaction from Metamask to Ronin using the ronin bridge system.

When the transaction was summitted the gas raised a lot, so my transaction was processing for 10 hours once it finally was automatically “dropped and replaced”.
When replaced, it automatically changed the destiny address, so instead of going to my Ronin wallet it went straight to a Ronin bridge contract address!!!??

Everything was absolutely correct, I made a $10usd transaction 5 minutes before to make sure and it worked out fine. I tried the seed phrase solution but nothing. I am desperate to receive my ether but it is hard to find help.

Transaction ID: 0x743ccef1744d5f5a07ece738217e154abb2530113e17e93a016c727db0fb583f

1 Like

yea, right seems legit

Hi. I happen to have made the same mistake. Isn’t there a way for us to ask for the Axie Infinity Team’s special help? since Ronin Bridge is their program, I’m pretty sure they have the mistakenly sent eth.

bro it happen to me too and axie didnt respon on this matter… lots of people losing money cuz of this incident,

1 Like

hopefully the @axieinfinityteam could help us with this matter.

Nobody is helping. Axie infinity team gave me a little attention on discord, once they realized with my help that the error was due a speed up using mobile app the simply blocked me and I can’t even send any message to them anymore.
This is ridiculous, many people are being screwed every day and they just don’t give a damn, their pockets are full anyway.