iPhone app not logging in (FaceID or password)

Hi David - I woke up this AM 9.13.21 , opened my MetaMask account and noticed something funny. I hit the browser button which is connected to my opensea account and a different website came up, GoDuckGo or something like that, then Yarn. I logged out and lost facial recognition. I logged back in using a password and still the same thing. Also, I am getting logged out of the mobile version when I step away, having to log back in again. My account is still intact and my chrome extension seems to be working properly. I see there have been issues with facial recognition in the past, but the browser issue freaks me out a bit. Please advise. I don’t want to lose everything.

TY! Al

Yes it did erase all my wallet information on my phone. That’s why you must have your seed phrase to reinstall the wallet. but when I reinstalled my wallet via the app using my seed phrase, all my accounts were absolutely in order.

However********
As a safety, I personally first used Chrome Browser on a computer that had never had my wallet to install the wallet with my seed phrase, which worked perfectly and all my assets were intact. I then transferred those assets into another wallet (in my case 1-inch) for safety. Then I reset/reinstalled the wallet with my seed phrase on my phone via the app, and the little bit of Etherium I had left in the wallet as a check was still there correctly. As was my 2nd account as well.

So yes it worked for me. But yes it does erase the info off the phone. Must have seed phrase to reinstall wallet. But I installed the wallet first on another clean device so I still had access to it in case the phone reinstall didn’t work. But the phone reinstall via the MetaMask app did work for me.

Whatever you guys from Metamask say: I use my wallet to store payments I receive from an inv estment. I am not continously trading nor looking all the time at the contents of my wallet. I have got more important things to do. So I get surprised by a new security feature. That is very fine - but I expect the “secret recovery phrase” to work and that when I use it, my accounts will appear. But they do not, all I get is an empty wallet on the firefox extension and a wallet with a different adress. And I am not the only one - so I beg you - get this fixed.

Thank you for the detailed info!!