Is there any solution?

i’m a newbie, really not very tech-savvy, when i used metamask i created 1 more account for BSC (because the default is ETH), and i always thought the recovery phrase was to restore the wallet and every account in the wallet belongs to a metamask wallet, so just using the recovery phrase will get all of them restored (obviously including all accounts) but until my laptop was stolen yesterday, i entered the passphrase on the new machine and the problem started appearing, my 2nd account didn’t have it, and after panicking I found out that in addition to the recovery phrase there is also a private key for each account too, I really don’t understand what’s the role of the recovery phrase here when just the private key can still be recovered, and now I’m really sad that I can’t cant get the money in my 2nd account even though i still have its wallet address, hope someone can help or suggest me how to solve this problem, the amount can l it’s small to you but it’s really big to me, i’m really desperate, god bless you and hope you guys don’t make the same mistake as me, if someone can help me i really know deep thanks

Hi @kakashi2927 try create next ETH account:

When the default account is correct :slightly_smiling_face: account 2 is still the same.

1 Like

thank you very much, i have tried without success, maybe the reason is because my 2nd account (the one i need to restore) is running on binance smart chain again, i am very desperate, anyway thanks for your help

Hmm and you added a BSC network? Your Account 1 is correct? (show correct eth address)

1 Like

yes, I read many topics on here and also see many people in the same situation, such errors have been around for a long time, why does metamask not warn when users create an account, or at least fix this error , too many keys (recovery phrase and private key) make a lot of people confused

@kakashi2927 strange :thinking: you have not imported Account 2 using a private key?

You can try to generate more ETH addresses :point_down: using this guide:
https://community.metamask.io/t/revert-transaction/11622/2

But in point :four: :upside_down_face: you not change Derivation Path

2 Likes

thank you very much, i’m trying it and if it works i will let you know, once again thank you very much

1 Like

hey my brother i made it, from the bottom of my heart i don’t know how to say thank you enough, god bless you and the people around you, have a good day so much fun and many blessings, once again I sincerely thank you, you are my benefactor, thank you very much

1 Like

I’m glad you solved it :smiley: :+1: good luck @kakashi2927

good luck

1 Like

Thank you, my benefactor

1 Like

Hi Luigi

I see you helped kakashi2927 and trust you will be able to do so for me as well?

I have my SECRET RECOVERY PHRASE and I have my PRIVATE KEY and RESTORED my wallet using my SECRET RECOVERY PHRASE. It did restore but not with my original wallet address.
As you may know, when wants to work with your NFT’s on OPENSEA and IMMUTABLE X, I have to connect to my MM wallet and then click on PROFILE (in OpenSea) or on MY INVENTORY (in Immutable X) to see and action anything to do with my NFT’s.
However that does not work anymore. I believe it is because of my new wallet/account address.
I fortunately have the old wallet/account address that I had in my origianl wallet and can even see my transactions on ETHERSCAN.

What can I do to “access” my NFT’s again please?

It’s not easy Daniel :slightly_smiling_face: @DanielBitLots

You use Windows 7 or 10? or new 11 :grin: the Internet browser?

Hi Luigi
You are truly a star my man. Thanks for responding!
I have Windows 10.

I did not know what country you are in (timelines), so how soon you would be able to help me.
Did not think it would be so soon.
Have battled with this for over a week already.
I started a new subject in my portfolio so I trust this is not doubling up?

My local time shows in my profile :slightly_smiling_face: you have the Backup :point_down: function turned on?

When this feature is turned on :upside_down_face: maybe you can restore old MetaMask wallet files

Windows-File-History

Thanks so far Luigi.
I’ve gone to through the process and I’m now at the point where I have to find the files I want to restore.
How do I find those relevant MetaMask files?
What would their file extension be?
The most likely files a laymen like me will think they are, wil be - webextension@metamask.io.xpi
Will they override my current extension?

I don’t know what browser you have :smiley:

For chrome browser is folder: C:\Users\USER_NAME\AppData\Local\Google\Chrome\User Data\Default\Local Extension Settings\nkbihfbeogaeaoehlefnkodbefgpgknn

My original wallet was in CHROME

So search for a folder: nkbihfbeogaeaoehlefnkodbefgpgknn
and try to restore the old version

Must I not try and restore the CHROME browser folder first?
nkbihfbeogaeaoehlefnkodbefgpgknn - Is this a file?