MetaMask Blank Screen on Firefox but no seed

Omg , this men just help me all the days during 1 week , he is so cool , He fixed my problem, while I thought that I would never find my metamask account, he is super cool, I have never seen someone so caring about me.
Positive Feedback :wink:


@Ninooow it took me a long time (4 days) :smiley: but I solved it YEAH :rocket:

dance Fire Meeeh :fire: :fire: :grin:


How to find MetaMask :fox_face: Vault Data in computer’s files (guide for Windows users)
if you use a Firefox browser and you can’t open your MetaMask wallet

:one: You need to know the password for your MetaMask :fox_face: wallet

:two: Ways to Find Your Firefox Profile Location in Windows:


:three: When you open a Firefox Profile folder: xxxxxxxx.default-release :point_up_2:

Open folder storage :point_up_2: and in the storage folder :file_folder: open the default :point_down: folder.


:four: How to find a MetaMask :fox_face: Internal UUID


:five: Now i know :slightly_smiling_face: that my MetaMask folders have a name: feaa69fe-435c-4dc8-8f73-9941fd189f56 your files will have another name.

MetaMask wallet folders

Open a folder with a longer name :point_down:

In this folder search file with number. My file is 709 :point_down: this file contains MetaMask vault data.


:six: Download and install EmEditor:


Right-click on your file :point_up_2: and open it in the program EmEditor

:seven: Search for words like: Keyr, data, d a t a, salt or s a l t :slightly_smiling_face:

:eight: Text editing :page_with_curl:

You have to find something like this:


Your data will look like this:

Click :point_up_2: Search -► Replace… or use the keyboard shortcut Ctrl + H
According to the picture above :roll_eyes: remove spaces in the text.

:nine: Download Vault Decryptor: and unzip this file to the your desktop :desktop_computer:

Open folder vault-decryptor-master -► and open index.html file in the browser firefox-icon

Paste the {“data”:} and use the password you set for your wallet in the MetaMask extension and click the “Decrypt” button :point_up_2: as shown in the video by MetaMask - Randy

:ten: Everything is done :smiley: and now you see your MetaMask seed phrase


PS: If your file contains more special characters :point_down: as in this picture

special characters

You need Ubuntu 21 or another linux system.

How to Install Ubuntu 21 on VirtualBox:

When you run Ubuntu :point_down: download and install: Snappy-fox

Launch a terminal in the folder snappy-fox:

and write a command: sudo apt install make gcc :point_up_2: confirm the installation by pressing Y

Then just compile the application :slightly_smiling_face: next command: make

Now you see :point_up_2: new file with name snappy-fox :slightly_smiling_face: everything is ready.

Now I’ll move my file :point_down: 709 to folder snappy-fox

and the last command is: ./snappy-fox 709 709.txt

last command

file 709.txt will be without special characters :smiley: yeah


I want to say that @Luigi was absolutely amazing in supporting me getting my seed phrase!! Friendly professional and worked about 9 straight hours to get this fixed!! Saved my NFT collection and some nodes!! This guys a saint!! Thank you brother and amazing job :pray::pray:


This is my longest tutorial on this forum :sweat_smile: it took me a long time
but the result is worth it :slightly_smiling_face: and I hope this tutorial will help a lot of people.

@Fondu3 Thank you so much for your positive rating Jesse :slightly_smiling_face:

I’m a monkeys savior now :smile: NFT monkeys


Hi there Luigi,
I made backup of this folder daily, but it didn’t help with data recovery.
SQLite files inside this folder structure are NOT agnostic. They relate to the original path, including the random-generated-sequence of the moz-extension+++ID.

Now I’m hard working in finding a way to force Firefox to adapt Metamask extension path to an ID that I will specify.
I do not know if it works.
In case of any idea please help.

Let’s say I have these data, I have my secret password, I have the 24 secret words.
This is not the problem.

As reported in this other post on this site:
I have my secret password, I have the 24 secret words. This is not the problem. **The problem is losing the bunch of configuration I had in metamask** : something such as 15+ subaccounts, each with multiple networks and tokens, for a total of 70+. It would be impossible to rebuild all of it.


Hi Luigi I have a white screen on metamask and need to recover my seed phrase :astonished: can you please help me walk threw this I have made progress but have a valuable collection and don’t want to screw anything up your help would be greatly appreciated



Hi @andrewfromqueens command below :point_down: does not work when the wallet cannot be opened‘data’, result => {
var vault =

Try to use my instructions :slightly_smiling_face: which you see above.


Thank you so much for your reply :sweat_smile: I am up to the em editor portion of the walk threw Im guessing I need to ignore the virus warning prompts and warning that says your files will be corrupted?


hehe EmEditor is a fast, lightweight, yet extensible, easy-to-use text editor for Windows

not a virus :smile:


already found my data in the emeditor but I found a bunch of special characters in it so im downloading ubuntu really appreciate your help


Special characters :point_down: you see behind the words: data, salt, iv?

If they aren’t behind the words: data, salt… You doesn’t need Ubuntu + Snappy-fox


okay my data actually does not have special characters after salt


Your data must look like this:


If the text contains :point_right: \ delete them


my data is not decrypting

1 Like

Oh :roll_eyes: you will need Ubuntu :smiley: I see a lot of special characters there.

1 Like

Okay will do im really hoping i can resolve this is super nerve wrecking thank you so much for your help


Don’t worry :smiley: you are deciphering the Egyptian hieroglyphs and Everything will be OK


I got back into my wallet thank you so much Luigi life saver :innocent: