Metamask Corrupted, No SPR, Have Password, Found Vault Info, Need Help

Hey everyone,

I’ve been an active MetaMask user for a few years now. Most of my crypto funds are on a ledger and I have SPR. However, I got a new computer and stupidly just setup a hot wallet without saving the SPR.

Two days ago, my computer restarted and I had a disc cleanup screen popup. Later that day, I went to login to my MetaMask on Firefox and have this issue:

Clicking restart MetaMask unfortunately does not resolve the issue.

After doing some research, I found a topic on here where Luigi responded with how to find my vault and decode it using Ubuntu.

I was able to successfully find my vault, decoded it using Ubuntu, and got all my data information. It looks good to me.

I also confirmed this is the right vault, the folder was created when I created this hot wallet, and when I inspect the vault, I see all sorts of urls that I have connected MetaMask with.

However, when I used MetaMask vault decoder and enter my password, I get an invalid password response.

I am 100% certain this is the correct password. I have tried the vault data with and without /.

Not sure where to go from here. Is there anyway I’m doing something wrong, or need to change something?

Willing to pay a data recovery specialist if they will be able to help me.

Some additional context, whenever I try to use the Chrome debugger to pull the vault info and confirm it’s accurate, I run into this error: “Uncaught Error: LavaMoat - property “chrome” of globalThis is inaccessible under scuttling mode. To learn more visit /LavaMoat/LavaMoat/pull/360.”

Thanks in advance for any help you all can give me. Will definitely tip handsomely if someone can help me resolve this.

Hi @captainnft420 I’m glad that my guide helped you :smiley: find vault data.

If you want :slightly_smiling_face: write to me on my telegram.
You can find it in my profile :smile: I’ll just have dinner and write you back.


Thank you, the guide was super helpful. Was my first time using Ubuntu, felt like a programmer for a second lol.

1 Like

Hey guys,

So this is where I am at:

  • Mates computer browser extension crashed… , I tried a few times … no luck…

I wasn’t familiar with MM so much at this stage so I proceeded to remove the extension and re-install…

Obviously this would have been ok at this stage if I went through the recovery steps and retrieved his 15 word secret phrase…

Then I thought I would add a create a new fresh wallet following the prompts.

So, If I was to go through the recovery process I would only find the 15 word secret phrase of the newly created wallet?

Is there anywhere the browser keeps logs of the previous extension data?

by the way, I do know the password for the original wallet…

@auslad man :see_no_evil: you lost old MetaMask data by reinstallation…


Like @Luigi mentioned, the recovery process would only find the phrase of the new wallet.

Was MetaMask downloaded on any other device?


This topic was automatically closed after 30 days. New replies are no longer allowed.