Metamask Error - Assistance Required

Hey everyone, I would really appreciate some help. I haven’t used my MetaMask wallet in prob 6-7 months. I get this error when I try to open it:

“MetaMask had trouble starting. This error could be intermittent, so try restarting the extension.”

The issue has occurred for hours at this point. When I click the “Restart” button, it does not fix the issue. My questions:

  1. If I uninstall the extension, then re-install + recover the wallet through my seed phrase – will that make me good to go?

  2. I had multiple accounts in the same wallet – I think like 20. And I had multiple chains added - ETH, BSC, Polygon, ONE, etc. If I recover the wallet using my seed phrase, will all those accounts show up again?

  3. Would updating my Mac OS fix the issue? I’m a few updates behind.

Also, I’d like to note that I had the same MetaMask wallet on another computer and on a phone – I can access Account 1 on the computer and Accounts 1 and 2 on the phone – but I don’t see the other accounts. I can however retrieve the primary Account 1 address if necessary.

Also, I tried clearing the cache etc on the browser and that did not work. The browser itself is fully updated to latest version.

Any help would be incredibly appreciated. Thank you.

3 Likes

hey @diamondwires , welcome to MetaMask community. :fox_face:

  1. Is your MetaMask up to date? Usually it will automatically upgrade after restarting the browser. Or you can click the Details button in the extension admin interface, then click Update. Then see if your MetaMask is back to normal.
    If it doesn’t work, you can try to delete and reinstall it. But before that make sure you have a backup of the seed phrase and preferably the private key of each address as well.

  2. Your wallet will not be lost. If your 20 addresses are all generated with the same seed phrase, after importing the wallet with the seed phrase, it will appear in the first wallet, then click create account, and all your addresses will appear. Alternatively, you can recover other addresses by importing the private key.

  3. My Mac OS is also not the latest system, but I can use MetaMask normally. It should be OS agnostic, it doesn’t have to be updated, but it’s up to you. :laughing:

You can use the exact same wallet on PC and mobile, one or more.and your question does not require address.

6 Likes

Have you resolved this? It’s been a week now and I’m still getting the same message using in Firefox and can’t get MetaMask to load

3 Likes

Hello @Mjz157 , welcome to MetaMask community.

Have you tried the solution provided by @tuya On this thread ?

3 Likes

Hi - I did and it’s still not working. Been over a week now on fire fox

1 Like

Hello @Mjz157, welcome to MetaMask community!

Make sure you have the latest version of Firefox and the latest version of the MetaMask extension. Clear cache, cookies and try again. If it still doesn’t work, remove MetaMask extension(provided you have your Secret Recovery Phrase safely stored by yourself) and reinstall the extension and implicitly your wallet with the 12 words and check if it’s all ok at this point.

If MetaMask wallet still has issues, install another browser(Chrome browser, for example), install MetaMask extension on it and import your Secret Recovery Phrase into it to restore your wallet.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.