Metamask hacked or bug?

I noticed that I have 0$ in my Metamask account.
I tried to investigate and saw that nothing was in activity tab, I check ETH transactions and nothing suspiscious, I checked BSC and still no activity. I check some missing assets and they have no activity. I try copy my walled id, but when I do so I get random ID copied (that is not mine) same on Chrome and Brave browser. I find where I have kept my ID and look up in etherscan.

I can see that all my coins were transferred back to original coin wallets (???) The same happened in BSC. It doesn’t seem that it went to some guys wallet so I don’t think it’s a hack cause to my understanding nothing got richer of of me.

Can someone explain what happened and can I do something about it?

(fyi I don’t have an easy access to my private key and I haven’t given any information of my wallet, I understand basic scams and I don’t visit suspicious websites)

Thank you all for your answers.

Opening a support ticket for you via email, please help to provide your account’s public address for us to further investigate, also what are the assets that are missing?

Can you help to clarify more on this "I can see that all my coins were transferred back to original coin wallets (???) "

Thank you. I replied to the email

1 Like


I can see how much matic I have on my Matic Mainnet but on my Etherium Mainnet shows no Eth and “Loading Tokens…” even though I should have over $300 USDC in there. Also a weird glitch where once I look at my Matic network with it’s 0.0005 Matic, all my other networks start showing 0.0005 Eth.

I removed and reinstalled the extension and it fixed it for me.