Metamask ledger connection

I have been having trouble with the MEtamask Ledgerx connection. When I follow the instructions to connect my ledger to Metamask all I see is the orange wheel thing spinning, it doesn’t connect. I’ve tried disabling my VPN and Firewall, cleaned the cache, cleaned system files, removed Metamask then added it back, tried with Chrome, Firefox, Opera, Edge, Brave, rebooted my system, just in case. The ledger works fine directly with the ledgerlive app but not with metamask. Does anyone have any idea what the issue may be? Just in case it may have been the ledger I bough a new one, set it up went through the same process to connect it to Metamask following the instructions. Same thing, The orange spinning lines
Any ideas? Thx


I just formatted a new hard drive installed windows 7. Metamask connected to ledger and functioned correctly for a few days. Then suddenly it quite working again. Not sure what the issue is yet. Is there some windows security issue I need to correct?

1 Like