Metamask SAME recoveryphrase DIFFRENT ADRESSES!

Hello,
when I yesterday after a long time have logged into my MM-wallet. I noticed that my address has changed. I have only once created a MM-wallet NEVER a second. In this wallet I used only the first account with the ending “db351” but suddenly it disappeared and it is the address with the ending “f5778” to find. I have read 6 hours of posts on this topic in forums.
I have restored my wallet several times. Now my first address is always the one with the ending “f5778” and no longer “db351”.
It is the correct recoveryphrase
It is the right netzewer (which is always given as the reason why you don’t see the coin/tokens)
BUT changing the network in metamask does NOT change the WALLETADDRESS.
Metamask has said no one can reproduce this error and it is not in the code. BUT IT IS!
I have also never imported a wallet because I did not know how to do it at the time.
The live support had passed the problem to the “technical team”.
They come but like everyone else only with the fact that you have the wrong network or the recovery phrase is wrong.
Or i have imported that account with a privatekey. NO I HAVE NOT!
So they are not helpful at all, because they do not understand that this error is not due to the users.

EXAMPLE!

If you create a wallet you get your 12 words the first address will be for example “0x765483” and the second address "0x99875 "even if you create 100.000 more addresses they will always be created in the same order when you add them. So if you delete MM and install it again you will have at the beginning only the address “0x765483”. As soon as you add the second one it is “0x99875” and so on.

But the problem i have now is that the SAME recovery phrase creates completely new addresses all of a sudden.Now every time i reinstall the MM-wallet the ending of the address is different than when it was created.

I hope someone can tell me something about this. I hope I could explain it so that even someone who does not have the problem can understand this.

I am german sorry for bad english.

thanks for help
with kind regards Sebastian

What if you try to use another Wallet instead of MetaMask, just for testing, and import your seed phrase into that wallet? I wonder what account it would recover

Hey, when i restore the wallet in Exodus its the adress with the ending “f5778” the old one isnt there.
I guess thats one of the problem wich cant be solved. :frowning:

What if you try to find out if your address ending with db351 really is part of your seed phrase ? I know you say that it is, but we can test it to be sure.

If you in the link below find Step 2, with the link with the Mnemonic account generator and input your seed phrase there. It can generate the accounts belonging to your seed phrase. I Just created a new MetaMask account with 3 sub accounts. And when I enter my seed phrase I can se the addresses of my 3 sub accounts - meaning that they are part of my seed phrase.

1 Like

I have done that already with 50.000 adresses. I tried everything for hours. I guess there is nothing i havent tried.
I just know that the wallet has replaced the old adress. (I know thats not possible or it should not be possible) but it obviously is. I cant recreat this bug/error but the bug is existing. I dont think so many peopl are just wrong.

Does Mnemonic account generator tells you, that your address is not part of your seed phrase ? If so, this is really weird

I dont know that. I just wrote my 12 words in the Mnemonic account generator and created 50.000 adress non of them is the right one.
How can i check if the adress is part auf my seed phrase?

NVM! Im the biggest dumbass in the world. I got my funds back! But still ty for help.

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.